mac80211/hostapd: rework 802.11w driver support selection, do not hardcode drivers...
[openwrt.git] / package / network / services / hostapd / Makefile
index c39b6b4..edcfd1b 100644 (file)
@@ -71,7 +71,7 @@ DRIVER_MAKEOPTS= \
        CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
 
 ifeq ($(LOCAL_VARIANT),full)
-  DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+  DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_DRIVER_11W_SUPPORT)
 endif
 
 ifneq ($(LOCAL_TYPE),hostapd)