fix and enable the sdk
[openwrt.git] / package / Makefile
index 2b7f0db..e947bcf 100644 (file)
@@ -27,9 +27,12 @@ $(STAMP_DIR) $(TARGET_DIR):
 %-clean: $(STAMP_DIR) $(TARGET_DIR)
        $(MAKE) -C $(patsubst %-clean,%,$@) clean MAKEFLAGS="$(BUILD_MAKEFLAGS)"
 
+ifeq ($(SDK),1)
+GENDEP_OPTS := -s
+endif
 
 $(TOPDIR)/.pkgdeps: $(TOPDIR)/.pkginfo
-       @$(TOPDIR)/scripts/gen_deps.pl < $< > $@ || rm -f $@
+       @$(TOPDIR)/scripts/gen_deps.pl $(GENDEP_OPTS) < $< > $@ || rm -f $@
 
 all: compile
 clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))