build: fix git prereq check to not rely on being in a git directory (#21968)
[openwrt.git] / include / prereq-build.mk
index 23a5b93..443b173 100644 (file)
@@ -155,7 +155,7 @@ $(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
        svn --version | grep Subversion))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
-       git submodule update --help 2>&1 | grep -- --recursive))
+       git submodule --help 2>&1 | grep -q -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))