add a packaging method that installs files into a subdirectory of bin/ instead of...
[openwrt.git] / include / package-bin.mk
diff --git a/include/package-bin.mk b/include/package-bin.mk
new file mode 100644 (file)
index 0000000..6ee7aed
--- /dev/null
@@ -0,0 +1,31 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+ifeq ($(DUMP),)
+  define BuildTarget/bin
+    ifdef Package/$(1)/install
+      ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
+        compile: install-bin-$(1)
+      else
+        compile: $(1)-disabled
+        $(1)-disabled:
+               @echo "WARNING: skipping $(1) -- package not selected"
+      endif
+    endif
+
+    install-bin-$(1): $(STAMP_BUILT)
+         rm -rf $(BIN_DIR)/$(1)
+         $(INSTALL_DIR) $(BIN_DIR)/$(1)
+         $(call Package/$(1)/install,$(BIN_DIR)/$(1))
+
+    clean-$(1):
+         rm -rf $(BIN_DIR)/$(1)
+
+    clean: clean-$(1)
+    .PHONY: install-bin-$(1)
+  endef
+endif