[tools] use HOST_STATIC_LINKING instead of hardcoding -static
[15.05/openwrt.git] / tools / mtools / Makefile
index 36f6adc..8d227c1 100644 (file)
@@ -16,7 +16,7 @@ PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) mcopy