CC: kernel: update kernel 3.18 to version 3.18.27
[15.05/openwrt.git] / target / linux / ramips / patches-3.18 / 500-alsa.patch
index 5c7e508..d43e7d5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/sound/soc/Kconfig
 +++ b/sound/soc/Kconfig
-@@ -56,6 +56,7 @@
+@@ -56,6 +56,7 @@ source "sound/soc/spear/Kconfig"
  source "sound/soc/tegra/Kconfig"
  source "sound/soc/txx9/Kconfig"
  source "sound/soc/ux500/Kconfig"
  source "sound/soc/codecs/Kconfig"
 --- a/sound/soc/Makefile
 +++ b/sound/soc/Makefile
-@@ -33,3 +33,4 @@
+@@ -33,3 +33,4 @@ obj-$(CONFIG_SND_SOC)        += spear/
  obj-$(CONFIG_SND_SOC) += tegra/
  obj-$(CONFIG_SND_SOC) += txx9/
  obj-$(CONFIG_SND_SOC) += ux500/
 +obj-$(CONFIG_SND_SOC)   += mtk/
 --- a/sound/soc/codecs/Kconfig
 +++ b/sound/soc/codecs/Kconfig
-@@ -725,7 +725,7 @@
+@@ -725,7 +725,7 @@ config SND_SOC_WM8955
        tristate
  
  config SND_SOC_WM8960
 +#endif
 --- a/sound/soc/soc-core.c
 +++ b/sound/soc/soc-core.c
-@@ -1851,7 +1851,8 @@
+@@ -1851,7 +1851,8 @@ static int soc_probe(struct platform_dev
        /* Bodge while we unpick instantiation */
        card->dev = &pdev->dev;
  
        {  0x4, 0x0000 },
        {  0x5, 0x0008 },
        {  0x6, 0x0000 },
-@@ -88,8 +88,8 @@
+@@ -88,8 +88,8 @@ static const struct reg_default wm8960_r
        { 0x25, 0x0050 },
        { 0x26, 0x0000 },
        { 0x27, 0x0000 },
        { 0x2a, 0x0040 },
        { 0x2b, 0x0000 },
        { 0x2c, 0x0000 },
-@@ -126,8 +126,7 @@
+@@ -126,8 +126,7 @@ struct wm8960_priv {
        bool deemph;
        int playback_fs;
  };
  
  /* enumerated controls */
  static const char *wm8960_polarity[] = {"No Inversion", "Left Inverted",
-@@ -181,8 +180,8 @@
+@@ -181,8 +180,8 @@ static int wm8960_get_deemph(struct snd_
        struct snd_soc_codec *codec = snd_soc_kcontrol_codec(kcontrol);
        struct wm8960_priv *wm8960 = snd_soc_codec_get_drvdata(codec);
  
  }
  
  static int wm8960_put_deemph(struct snd_kcontrol *kcontrol,
-@@ -200,6 +199,65 @@
+@@ -200,6 +199,65 @@ static int wm8960_put_deemph(struct snd_
        return wm8960_set_deemph(codec);
  }
  
  static const DECLARE_TLV_DB_SCALE(adc_tlv, -9700, 50, 0);
  static const DECLARE_TLV_DB_SCALE(dac_tlv, -12700, 50, 1);
  static const DECLARE_TLV_DB_SCALE(bypass_tlv, -2100, 300, 0);
-@@ -542,6 +600,9 @@
+@@ -542,6 +600,9 @@ static int wm8960_set_dai_fmt(struct snd
  
        /* set iface */
        snd_soc_write(codec, WM8960_IFACE1, iface);
        return 0;
  }
  
-@@ -623,11 +684,15 @@
+@@ -623,11 +684,15 @@ static int wm8960_set_bias_level_out3(st
                break;
  
        case SND_SOC_BIAS_PREPARE:
                if (codec->dapm.bias_level == SND_SOC_BIAS_OFF) {
                        regcache_sync(wm8960->regmap);
  
-@@ -650,9 +715,13 @@
+@@ -650,9 +715,13 @@ static int wm8960_set_bias_level_out3(st
  
                /* Set VMID to 2x250k */
                snd_soc_update_bits(codec, WM8960_POWER1, 0x180, 0x100);
                /* Enable anti-pop features */
                snd_soc_write(codec, WM8960_APOP1,
                             WM8960_POBCTRL | WM8960_SOFT_ST |
-@@ -661,6 +730,7 @@
+@@ -661,6 +730,7 @@ static int wm8960_set_bias_level_out3(st
                /* Disable VMID and VREF, let them discharge */
                snd_soc_write(codec, WM8960_POWER1, 0);
                msleep(600);
                break;
        }
  
-@@ -853,7 +923,6 @@
+@@ -853,7 +923,6 @@ static int wm8960_set_dai_pll(struct snd
  
        if (pll_div.k) {
                reg |= 0x20;
                snd_soc_write(codec, WM8960_PLL2, (pll_div.k >> 16) & 0xff);
                snd_soc_write(codec, WM8960_PLL3, (pll_div.k >> 8) & 0xff);
                snd_soc_write(codec, WM8960_PLL4, pll_div.k & 0xff);
-@@ -962,7 +1031,7 @@
+@@ -962,7 +1031,7 @@ static int wm8960_probe(struct snd_soc_c
  {
        struct wm8960_priv *wm8960 = snd_soc_codec_get_drvdata(codec);
        struct wm8960_data *pdata = dev_get_platdata(codec->dev);
  
        wm8960->set_bias_level = wm8960_set_bias_level_out3;
  
-@@ -973,26 +1042,9 @@
+@@ -973,26 +1042,9 @@ static int wm8960_probe(struct snd_soc_c
                        wm8960->set_bias_level = wm8960_set_bias_level_capless;
        }