kernel: update 3.14 to 3.14.18
[15.05/openwrt.git] / target / linux / ipq806x / patches / 0144-phy-qcom-Add-driver-for-QCOM-IPQ806x-SATA-PHY.patch
index 862be08..9a5457d 100644 (file)
@@ -14,8 +14,6 @@ Signed-off-by: Kumar Gala <galak@codeaurora.org>
  3 files changed, 219 insertions(+)
  create mode 100644 drivers/phy/phy-qcom-ipq806x-sata.c
 
-diff --git a/drivers/phy/Kconfig b/drivers/phy/Kconfig
-index c7a551c..3642a65 100644
 --- a/drivers/phy/Kconfig
 +++ b/drivers/phy/Kconfig
 @@ -65,4 +65,11 @@ config BCM_KONA_USB2_PHY
@@ -30,18 +28,13 @@ index c7a551c..3642a65 100644
 +      select GENERIC_PHY
 +
  endmenu
-diff --git a/drivers/phy/Makefile b/drivers/phy/Makefile
-index b57c253..74f78cc 100644
 --- a/drivers/phy/Makefile
 +++ b/drivers/phy/Makefile
-@@ -9,3 +9,4 @@ obj-$(CONFIG_PHY_EXYNOS_MIPI_VIDEO)    += phy-exynos-mipi-video.o
+@@ -9,3 +9,4 @@ obj-$(CONFIG_PHY_EXYNOS_MIPI_VIDEO)    += p
  obj-$(CONFIG_PHY_MVEBU_SATA)          += phy-mvebu-sata.o
  obj-$(CONFIG_OMAP_USB2)                       += phy-omap-usb2.o
  obj-$(CONFIG_TWL4030_USB)             += phy-twl4030-usb.o
 +obj-$(CONFIG_PHY_QCOM_IPQ806X_SATA)   += phy-qcom-ipq806x-sata.o
-diff --git a/drivers/phy/phy-qcom-ipq806x-sata.c b/drivers/phy/phy-qcom-ipq806x-sata.c
-new file mode 100644
-index 0000000..e931aee
 --- /dev/null
 +++ b/drivers/phy/phy-qcom-ipq806x-sata.c
 @@ -0,0 +1,211 @@
@@ -256,6 +249,3 @@ index 0000000..e931aee
 +
 +MODULE_DESCRIPTION("QCOM IPQ806x SATA PHY driver");
 +MODULE_LICENSE("GPL v2");
--- 
-1.7.10.4
-