firmware-utils: move bcm_tag.h here
[15.05/openwrt.git] / package / openssl / patches / 150-no_engines.patch
index b928fbc..62aacc1 100644 (file)
@@ -1,7 +1,20 @@
-diff -udrNP openssl-0.9.8-stable-SNAP-20050703.orig/util/libeay.num openssl-0.9.8-stable-SNAP-20050703/util/libeay.num
---- openssl-0.9.8-stable-SNAP-20050703.orig/util/libeay.num    2005-07-04 00:27:14.653639088 +0200
-+++ openssl-0.9.8-stable-SNAP-20050703/util/libeay.num 2005-07-04 22:50:07.986576664 +0200
-@@ -2071,7 +2071,6 @@
+--- a/Configure
++++ b/Configure
+@@ -2000,6 +2000,11 @@ EOF
+       close(OUT);
+   }
+   
++# ugly hack to disable engines
++if($target eq "mingwx") {
++      system("sed -e s/^LIB/XLIB/g -i engines/Makefile");
++}
++
+ print <<EOF;
+ Configured for $target.
+--- a/util/libeay.num
++++ b/util/libeay.num
+@@ -2071,7 +2071,6 @@ PKCS7_ATTR_SIGN_it                      
  UI_add_error_string                     2633  EXIST::FUNCTION:
  KRB5_CHECKSUM_free                      2634  EXIST::FUNCTION:
  OCSP_REQUEST_get_ext                    2635  EXIST::FUNCTION:
@@ -9,7 +22,7 @@ diff -udrNP openssl-0.9.8-stable-SNAP-20050703.orig/util/libeay.num openssl-0.9.
  ENGINE_register_all_digests             2637  EXIST::FUNCTION:ENGINE
  PKEY_USAGE_PERIOD_it                    2638  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
  PKEY_USAGE_PERIOD_it                    2638  EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
-@@ -2545,7 +2544,6 @@
+@@ -2545,7 +2544,6 @@ OCSP_RESPONSE_new                       
  AES_set_encrypt_key                     3024  EXIST::FUNCTION:AES
  OCSP_resp_count                         3025  EXIST::FUNCTION:
  KRB5_CHECKSUM_new                       3026  EXIST::FUNCTION:
@@ -17,7 +30,7 @@ diff -udrNP openssl-0.9.8-stable-SNAP-20050703.orig/util/libeay.num openssl-0.9.
  OCSP_onereq_get0_id                     3028  EXIST::FUNCTION:
  ENGINE_set_default_ciphers              3029  EXIST::FUNCTION:ENGINE
  NOTICEREF_it                            3030  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
-@@ -2576,7 +2574,6 @@
+@@ -2576,7 +2574,6 @@ ASN1_primitive_free                     
  i2d_EXTENDED_KEY_USAGE                  3052  EXIST::FUNCTION:
  i2d_OCSP_SIGNATURE                      3053  EXIST::FUNCTION:
  asn1_enc_save                           3054  EXIST::FUNCTION:
@@ -25,7 +38,7 @@ diff -udrNP openssl-0.9.8-stable-SNAP-20050703.orig/util/libeay.num openssl-0.9.
  _ossl_old_des_pcbc_encrypt              3056  EXIST::FUNCTION:DES
  PKCS12_MAC_DATA_it                      3057  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
  PKCS12_MAC_DATA_it                      3057  EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
-@@ -2600,7 +2597,6 @@
+@@ -2600,7 +2597,6 @@ asn1_get_choice_selector                
  i2d_KRB5_CHECKSUM                       3072  EXIST::FUNCTION:
  ENGINE_set_table_flags                  3073  EXIST::FUNCTION:ENGINE
  AES_options                             3074  EXIST::FUNCTION:AES
@@ -33,7 +46,7 @@ diff -udrNP openssl-0.9.8-stable-SNAP-20050703.orig/util/libeay.num openssl-0.9.
  OCSP_id_cmp                             3076  EXIST::FUNCTION:
  OCSP_BASICRESP_new                      3077  EXIST::FUNCTION:
  OCSP_REQUEST_get_ext_by_NID             3078  EXIST::FUNCTION:
-@@ -2667,7 +2663,6 @@
+@@ -2667,7 +2663,6 @@ OCSP_CRLID_it                           
  OCSP_CRLID_it                           3127  EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
  i2d_KRB5_AUTHENTBODY                    3128  EXIST::FUNCTION:
  OCSP_REQUEST_get_ext_count              3129  EXIST::FUNCTION:
@@ -41,7 +54,7 @@ diff -udrNP openssl-0.9.8-stable-SNAP-20050703.orig/util/libeay.num openssl-0.9.
  X509_NAME_it                            3131  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
  X509_NAME_it                            3131  EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
  USERNOTICE_it                           3132  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
-@@ -2762,8 +2757,6 @@
+@@ -2762,8 +2757,6 @@ DES_read_2passwords                     
  DES_read_password                       3207  EXIST::FUNCTION:DES
  UI_UTIL_read_pw                         3208  EXIST::FUNCTION:
  UI_UTIL_read_pw_string                  3209  EXIST::FUNCTION:
@@ -50,7 +63,7 @@ diff -udrNP openssl-0.9.8-stable-SNAP-20050703.orig/util/libeay.num openssl-0.9.
  OPENSSL_add_all_algorithms_noconf       3212  EXIST:!VMS:FUNCTION:
  OPENSSL_add_all_algo_noconf             3212  EXIST:VMS:FUNCTION:
  OPENSSL_add_all_algorithms_conf         3213  EXIST:!VMS:FUNCTION:
-@@ -2772,7 +2765,6 @@
+@@ -2772,7 +2765,6 @@ OPENSSL_load_builtin_modules            
  AES_ofb128_encrypt                      3215  EXIST::FUNCTION:AES
  AES_ctr128_encrypt                      3216  EXIST::FUNCTION:AES
  AES_cfb128_encrypt                      3217  EXIST::FUNCTION:AES
@@ -58,26 +71,11 @@ diff -udrNP openssl-0.9.8-stable-SNAP-20050703.orig/util/libeay.num openssl-0.9.
  _ossl_096_des_random_seed               3219  EXIST::FUNCTION:DES
  EVP_aes_256_ofb                         3220  EXIST::FUNCTION:AES
  EVP_aes_192_ofb                         3221  EXIST::FUNCTION:AES
-@@ -3107,7 +3099,6 @@
- STORE_method_set_modify_function        3530  EXIST:!VMS:FUNCTION:
- STORE_meth_set_modify_fn                3530  EXIST:VMS:FUNCTION:
- STORE_parse_attrs_next                  3531  EXIST::FUNCTION:
--ENGINE_load_padlock                     3532  EXIST::FUNCTION:ENGINE
+@@ -3107,7 +3099,6 @@ EC_GFp_nist_method                      
+ STORE_meth_set_modify_fn                3530  NOEXIST::FUNCTION:
+ STORE_method_set_modify_function        3530  NOEXIST::FUNCTION:
+ STORE_parse_attrs_next                  3531  NOEXIST::FUNCTION:
+-ENGINE_load_padlock                     3532  EXIST::FUNCTION:ENGINE,STATIC_ENGINE
  EC_GROUP_set_curve_name                 3533  EXIST::FUNCTION:EC
  X509_CERT_PAIR_it                       3534  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
  X509_CERT_PAIR_it                       3534  EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
-diff -udrNP openssl-0.9.8-stable-SNAP-20050703.orig/Configure openssl-0.9.8-stable-SNAP-20050703/Configure
---- openssl-0.9.8-stable-SNAP-20050703.orig/Configure  2005-07-04 00:27:11.169168808 +0200
-+++ openssl-0.9.8-stable-SNAP-20050703/Configure       2005-07-05 00:02:12.590136992 +0200
-@@ -1623,6 +1624,11 @@
-       close(OUT);
-   }
-   
-+# ugly hack to disable engines
-+if($target eq "mingwx") {
-+      system("sed -e s/^LIB/XLIB/g -i engines/Makefile");
-+}
-+  
- print <<EOF;
- Configured for $target.