bcm63xx: pad Speedport W303 V images to 4 MiB
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 May 2012 13:22:22 +0000 (13:22 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 May 2012 13:22:22 +0000 (13:22 +0000)
Prevents CFE from flashing to the second image offset. Fix up the rootfs
length on first boot else CFE will complain.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31876 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/image/Makefile

index f82647e..303003c 100644 (file)
@@ -93,7 +93,7 @@ define Image/Build/SPW303V
                --output $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin.tmp \
                --boardid $(2) --chipid $(3) --entry $(KERNEL_ENTRY) \
                --load-addr $(LOADADDR) --rsa-signature "$(5)" \
-               $(6) $(7) $(8) $(9)
+               --pad 4 $(6) $(7) $(8) $(9)
        # Fix up header
        $(STAGING_DIR_HOST)/bin/spw303v -i $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin.tmp \
                -o $(BIN_DIR)/openwrt-$(4)-$(1)-cfe-sysupgrade.bin