projects
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
dca0ad3
)
fix curl compile
author
nbd
<nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Jan 2008 13:16:47 +0000
(13:16 +0000)
committer
nbd
<nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Jan 2008 13:16:47 +0000
(13:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10204
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
libs/curl/Makefile
patch
|
blob
|
history
diff --git
a/libs/curl/Makefile
b/libs/curl/Makefile
index
8f3abf2
..
0f80736
100644
(file)
--- a/
libs/curl/Makefile
+++ b/
libs/curl/Makefile
@@
-78,14
+78,17
@@
CONFIGURE_ARGS += \
CONFIGURE_VARS += \
LDFLAGS="$$$$LDFLAGS -lcrypto -lssl -lz" \
-
+ CC="$(filter-out ccache,$(TARGET_CC))"
define Build/Configure
$(call Build/Configure/Default,,bash)
endef
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ CC="$(TARGET_CC)" \
+ install
endef
define Build/InstallDev