add --without-x to dsniff compile and add mostlyclean target
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jun 2005 20:18:17 +0000 (20:18 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jun 2005 20:18:17 +0000 (20:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1222 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/dsniff/Makefile

index 6d6b606..3355eb8 100644 (file)
@@ -43,6 +43,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
                  --sbindir=/usr/sbin \
                  --sysconfdir=/etc \
                  --without-db \
+                 --without-x \
                  --with-gdbm="$(STAGING_DIR)/usr" \
                  --with-libnids="$(STAGING_DIR)/usr" \
                  --with-libpcap="$(STAGING_DIR)/usr" \
@@ -69,3 +70,7 @@ $(IPKG_DSNIFF):
        cp -fpR  $(PKG_INSTALL_DIR)/usr/lib/* $(IDIR_DSNIFF)/usr/lib
        $(RSTRIP) $(IDIR_DSNIFF)
        $(IPKG_BUILD) $(IDIR_DSNIFF) $(PACKAGE_DIR)
+
+mostlyclean:
+       make -C $(PKG_BUILD_DIR) clean
+       rm $(PKG_BUILD_DIR)/.built