mpc83xx: populate network config from an uci-default script
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 May 2012 11:43:19 +0000 (11:43 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 May 2012 11:43:19 +0000 (11:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31590 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/mpc83xx/base-files.mk [new file with mode: 0644]
target/linux/mpc83xx/base-files/etc/uci-defaults/network [new file with mode: 0755]
target/linux/mpc83xx/base-files/lib/mpc83xx.sh [new file with mode: 0755]
target/linux/mpc83xx/base-files/lib/preinit/03_preinit_do_mpc83xx.sh [new file with mode: 0644]

diff --git a/target/linux/mpc83xx/base-files.mk b/target/linux/mpc83xx/base-files.mk
new file mode 100644 (file)
index 0000000..d6682bd
--- /dev/null
@@ -0,0 +1,5 @@
+define Package/base-files/install-target
+       rm -f $(1)/etc/config/network
+endef
+
+
diff --git a/target/linux/mpc83xx/base-files/etc/uci-defaults/network b/target/linux/mpc83xx/base-files/etc/uci-defaults/network
new file mode 100755 (executable)
index 0000000..a3467aa
--- /dev/null
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+[ -e /etc/config/network ] && exit 0
+
+touch /etc/config/network
+
+. /lib/functions/uci-defaults.sh
+. /lib/mpc83xx.sh
+
+ucidef_set_interface_loopback
+
+board=$(mpc83xx_board_name)
+
+case "$board" in
+rb333)
+       ucidef_set_interfaces_lan_wan "eth0 eth1" "eth2"
+       ;;
+
+*)
+       ucidef_set_interfaces_lan_wan "eth0" "eth1"
+       ;;
+esac
+
+uci commit network
+
+exit 0
diff --git a/target/linux/mpc83xx/base-files/lib/mpc83xx.sh b/target/linux/mpc83xx/base-files/lib/mpc83xx.sh
new file mode 100755 (executable)
index 0000000..ea8e346
--- /dev/null
@@ -0,0 +1,44 @@
+#!/bin/sh
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+MPC83XX_BOARD_NAME=
+MPC83XX_MODEL=
+
+mpc83xx_board_detect() {
+       local model
+       local name
+
+       model=$(awk 'BEGIN{FS="[ \t]+:[ \t]"} /model/ {print $2}' /proc/cpuinfo)
+
+       case "$model" in
+       "RB333")
+               name="rb333"
+               model="MikroTik RouterBOARD 333"
+               ;;
+       "RB600")
+               name="rb600"
+               model="MikroTik RouterBOARD 600"
+               ;;
+       esac
+
+       [ -z "$name" ] && name="unknown"
+
+       [ -z "$MPC83XX_BOARD_NAME" ] && MPC83XX_BOARD_NAME="$name"
+       [ -z "$MPC83XX_MODEL" ] && MPC83XX_MODEL="$model"
+
+       [ -e "/tmp/sysinfo/" ] || mkdir -p "/tmp/sysinfo/"
+
+       echo "$MPC83XX_BOARD_NAME" > /tmp/sysinfo/board_name
+       echo "$MPC83XX_MODEL" > /tmp/sysinfo/model
+}
+
+mpc83xx_board_name() {
+       local name
+
+       [ -f /tmp/sysinfo/board_name ] && name=$(cat /tmp/sysinfo/board_name)
+       [ -z "$name" ] && name="unknown"
+
+       echo "$name"
+}
diff --git a/target/linux/mpc83xx/base-files/lib/preinit/03_preinit_do_mpc83xx.sh b/target/linux/mpc83xx/base-files/lib/preinit/03_preinit_do_mpc83xx.sh
new file mode 100644 (file)
index 0000000..c67b1d4
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+do_mpc83xx() {
+       . /lib/mpc83xx.sh
+
+       mpc83xx_board_detect
+}
+
+boot_hook_add preinit_main do_mpc83xx