luci-0.9: merge r5534
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 11 Nov 2009 23:19:32 +0000 (23:19 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 11 Nov 2009 23:19:32 +0000 (23:19 +0000)
contrib/package/luci/Makefile

index 6503985..c631519 100644 (file)
@@ -83,6 +83,11 @@ define Package/luci/webtemplate
   SUBMENU:=Components
 endef
 
+define Package/luci/collectiontemplate
+  $(call Package/luci/libtemplate)
+  SUBMENU:=Collections
+endef
+
 
 define Package/luci/install/template
        $(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
@@ -873,6 +878,19 @@ define Package/luci-i18n-spanish/install
 endef
 
 
+### Collections ###
+define Package/luci-kamikaze
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Standard OpenWrt Kamikaze set including full and mini admin and the standard theme
+  DEPENDS:=+luci-admin-full +luci-admin-mini +luci-theme-openwrt +luci-app-firewall
+endef
+
+define Package/luci-light
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Minimum package set using only admin mini and a theme without grafics
+  DEPENDS:=+luci-admin-mini +luci-theme-openwrtlight
+endef
+
 ### Compile ###
 ifneq ($(CONFIG_PACKAGE_luci-core),)
        PKG_SELECTED_MODULES+=libs/core
@@ -1153,3 +1171,6 @@ $(eval $(call BuildPackage,luci-i18n-greek))
 $(eval $(call BuildPackage,luci-i18n-catalan))
 $(eval $(call BuildPackage,luci-i18n-portuguese))
 $(eval $(call BuildPackage,luci-i18n-spanish))
+
+$(eval $(call BuildPackage,luci-kamikaze))
+$(eval $(call BuildPackage,luci-light))