[packages_10.03.2] python: merge r29276, r29277, r29369
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 18:21:32 +0000 (18:21 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 18:21:32 +0000 (18:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30037 3c298f89-4303-0410-b956-a3cf2f4a3e73

12 files changed:
lang/python/Makefile
lang/python/patches/000-cross-compile.patch
lang/python/patches/010-cannot-run-test-programm.patch
lang/python/patches/011-linux-3.x-compat.patch [new file with mode: 0644]
lang/python/patches/020-dont-compile-python-files.patch
lang/python/patches/030-fixup-include-dirs.patch
lang/python/patches/040-dont-import-cross-compiled-modules.patch
lang/python/patches/070-dont-clean-ipkg-install.patch
lang/python/patches/080-distutils-dont_adjust_files.patch
lang/python/patches/090-fix-ctypes.patch
lang/python/patches/110-enable-zlib.patch
lang/python/patches/120-force-internal-modules-for-hashlib.patch

index dd8d883..68d6b6f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python
 PKG_VERSION:=2.6.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
@@ -75,6 +75,12 @@ $(call Package/python/Default)
   DEPENDS+=+python-mini
 endef
 
+define Package/python-bzip2
+$(call Package/python/Default)
+  TITLE:=Python support for Bzip2
+  DEPENDS+=+python-mini +libbz2
+endef
+
 define Package/python-expat
 $(call Package/python/Default)
   TITLE:=Python support for expat
@@ -195,6 +201,7 @@ define PyPackage/python/filespec
 -|/usr/lib/python$(PYTHON_VERSION)/test
 -|/usr/lib/python$(PYTHON_VERSION)/lib2to3
 -|/usr/lib/python$(PYTHON_VERSION)/lib-old
+-|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/bz2.so
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/gdbm.so
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_sqlite3.so
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_ssl.so
@@ -239,7 +246,6 @@ define PyPackage/python/filespec
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/syslog.so
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/time.so
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/unicodedata.so
--|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/zlib.so
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_weakref.so
 -|/usr/lib/python$(PYTHON_VERSION)/linecache.py
 -|/usr/lib/python$(PYTHON_VERSION)/md5.py
@@ -318,7 +324,6 @@ define PyPackage/python-mini/filespec
 +|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/syslog.so
 +|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/time.so
 +|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/unicodedata.so
-+|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/zlib.so
 +|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_weakref.so
 +|/usr/lib/python$(PYTHON_VERSION)/linecache.py
 +|/usr/lib/python$(PYTHON_VERSION)/md5.py
@@ -369,6 +374,10 @@ define PyPackage/python-doc/filespec
 +|/usr/lib/python$(PYTHON_VERSION)/pydoc.py
 endef
 
+define PyPackage/python-bzip2/filespec
++|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/bz2.so
+endef
+
 define PyPackage/python-expat/filespec
 +|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/pyexpat.so
 endef
@@ -427,6 +436,7 @@ $(eval $(call HostBuild))
 $(eval $(call PyPackage,python))
 $(eval $(call PyPackage,python-mini))
 $(eval $(call PyPackage,python-doc))
+$(eval $(call PyPackage,python-bzip2))
 $(eval $(call PyPackage,python-expat))
 $(eval $(call PyPackage,python-gzip))
 $(eval $(call PyPackage,python-openssl))
@@ -437,6 +447,7 @@ $(eval $(call PyPackage,python-gdbm))
 $(eval $(call BuildPackage,python))
 $(eval $(call BuildPackage,python-mini))
 $(eval $(call BuildPackage,python-doc))
+$(eval $(call BuildPackage,python-bzip2))
 $(eval $(call BuildPackage,python-expat))
 $(eval $(call BuildPackage,python-gzip))
 $(eval $(call BuildPackage,python-openssl))
index dc2e166..efbe070 100644 (file)
@@ -2,8 +2,8 @@
  Makefile.pre.in |   25 +++++++++++++------------
  1 file changed, 13 insertions(+), 12 deletions(-)
 
---- Python-2.6.4.orig/Makefile.pre.in
-+++ Python-2.6.4/Makefile.pre.in
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
 @@ -175,6 +175,7 @@ UNICODE_OBJS=   @UNICODE_OBJS@
  
  PYTHON=               python$(EXE)
index 471f008..c981b46 100644 (file)
@@ -2,8 +2,8 @@
  configure.in |   46 ++++++++++++++++++++++++++++++++++------------
  1 file changed, 34 insertions(+), 12 deletions(-)
 
---- Python-2.6.4.orig/configure.in
-+++ Python-2.6.4/configure.in
+--- a/configure.in
++++ b/configure.in
 @@ -2653,6 +2653,7 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_
  # On Tru64, chflags seems to be present, but calling it will
  # exit Python
diff --git a/lang/python/patches/011-linux-3.x-compat.patch b/lang/python/patches/011-linux-3.x-compat.patch
new file mode 100644 (file)
index 0000000..088618d
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/configure
++++ b/configure
+@@ -2070,6 +2070,7 @@ then
+       MACHDEP="$ac_md_system$ac_md_release"
+       case $MACHDEP in
++      linux3) MACHDEP="linux2";;
+       cygwin*) MACHDEP="cygwin";;
+       darwin*) MACHDEP="darwin";;
+       atheos*) MACHDEP="atheos";;
+--- a/configure.in
++++ b/configure.in
+@@ -240,6 +240,7 @@ then
+       MACHDEP="$ac_md_system$ac_md_release"
+       case $MACHDEP in
++      linux3) MACHDEP="linux2";;
+       cygwin*) MACHDEP="cygwin";;
+       darwin*) MACHDEP="darwin";;
+       atheos*) MACHDEP="atheos";;
index b3dd89d..d9c092b 100644 (file)
@@ -2,8 +2,8 @@
  Makefile.pre.in |   16 ----------------
  1 file changed, 16 deletions(-)
 
---- Python-2.6.4.orig/Makefile.pre.in
-+++ Python-2.6.4/Makefile.pre.in
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
 @@ -887,22 +887,6 @@ libinstall:       build_all $(srcdir)/Lib/$(PL
                done; \
        done
index ad00956..409b3e6 100644 (file)
@@ -2,8 +2,8 @@
  setup.py |   15 ++-------------
  1 file changed, 2 insertions(+), 13 deletions(-)
 
---- Python-2.6.4.orig/setup.py
-+++ Python-2.6.4/setup.py
+--- a/setup.py
++++ b/setup.py
 @@ -309,9 +309,6 @@ class PyBuildExt(build_ext):
          return sys.platform
  
index 85e1e7e..5c99598 100644 (file)
@@ -2,8 +2,8 @@
  setup.py |   30 ------------------------------
  1 file changed, 30 deletions(-)
 
---- Python-2.6.4.orig/setup.py
-+++ Python-2.6.4/setup.py
+--- a/setup.py
++++ b/setup.py
 @@ -270,36 +270,6 @@ class PyBuildExt(build_ext):
          ext_filename = os.path.join(
              self.build_lib,
index 0eee56b..593bcff 100644 (file)
@@ -2,8 +2,8 @@
  Makefile.pre.in |    6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)
 
---- Python-2.6.4.orig/Makefile.pre.in
-+++ Python-2.6.4/Makefile.pre.in
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
 @@ -1118,11 +1118,11 @@ TAGS::
  # Sanitation targets -- clean leaves libraries, executables and tags
  # files, which clobber removes as well
index c4798e5..a32e034 100644 (file)
@@ -2,8 +2,8 @@
  Lib/distutils/command/build_scripts.py |   43 +++------------------------------
  1 file changed, 4 insertions(+), 39 deletions(-)
 
---- Python-2.6.4.orig/Lib/distutils/command/build_scripts.py
-+++ Python-2.6.4/Lib/distutils/command/build_scripts.py
+--- a/Lib/distutils/command/build_scripts.py
++++ b/Lib/distutils/command/build_scripts.py
 @@ -54,10 +54,7 @@ class build_scripts (Command):
  
  
index 616e76d..6e93182 100644 (file)
@@ -2,9 +2,9 @@
  Lib/ctypes/__init__.py |    6 ------
  1 file changed, 6 deletions(-)
 
---- Python-2.6.4.orig/Lib/ctypes/__init__.py
-+++ Python-2.6.4/Lib/ctypes/__init__.py
-@@ -538,9 +538,3 @@ for kind in [c_ushort, c_uint, c_ulong,
+--- a/Lib/ctypes/__init__.py
++++ b/Lib/ctypes/__init__.py
+@@ -538,9 +538,3 @@ for kind in [c_ushort, c_uint, c_ulong, 
      elif sizeof(kind) == 4: c_uint32 = kind
      elif sizeof(kind) == 8: c_uint64 = kind
  del(kind)
index ac2e051..cdc7073 100644 (file)
@@ -2,8 +2,8 @@
  Modules/Setup.dist |    2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
---- Python-2.6.4.orig/Modules/Setup.dist
-+++ Python-2.6.4/Modules/Setup.dist
+--- a/Modules/Setup.dist
++++ b/Modules/Setup.dist
 @@ -460,7 +460,7 @@ GLHACK=-Dclear=__GLclear
  # Andrew Kuchling's zlib module.
  # This require zlib 1.1.3 (or later).
index f0bdeef..ca29aa6 100644 (file)
@@ -2,8 +2,8 @@
  setup.py |   10 ++++++----
  1 file changed, 6 insertions(+), 4 deletions(-)
 
---- Python-2.6.4.orig/setup.py
-+++ Python-2.6.4/setup.py
+--- a/setup.py
++++ b/setup.py
 @@ -622,9 +622,10 @@ class PyBuildExt(build_ext):
  
          #print 'openssl_ver = 0x%08x' % openssl_ver