Final updates to default configuration of ps3 petitboot sub-target
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Mar 2009 16:02:52 +0000 (16:02 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Mar 2009 16:02:52 +0000 (16:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14918 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk
target/linux/ps3/Makefile
target/linux/ps3/petitboot/target.mk

index 5d8baea..baca4b5 100644 (file)
@@ -15,6 +15,7 @@ DEVICE_TYPE?=router
 DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg
 # For router targets
 DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall
+DEFAULT_PACKAGES.bootloader:=kexec-tools
 
 # Additional packages for Linux 2.6
 ifneq ($(KERNEL),2.4)
index 2984019..4b2519b 100644 (file)
@@ -12,6 +12,8 @@ BOARDNAME:=Sony PS3 Game Console
 MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
 SUBTARGETS=petitboot
 
+DEVICE_TYPE=bootloader
+
 LINUX_VERSION:=2.6.28.8
 
 KERNEL_CC:=
index 5f16ba4..a3d84dd 100644 (file)
@@ -1,7 +1,8 @@
 BOARDNAME:=Petitboot
-DEVICE_TYPE:=bootloader
 FEATURES:=fpu
 
+DEFAULT_PACKAGES+= dnsmasq
+
 define Target/Description
        Build Petitboot bootloader
 endef