contrib/freifunk-gwcheck: Fix uci-defaults, add olsrd-mod-dyn-gw-plain depency
authorManuel Munz <freifunk@somakoma.de>
Fri, 23 Sep 2011 19:45:39 +0000 (19:45 +0000)
committerManuel Munz <freifunk@somakoma.de>
Fri, 23 Sep 2011 19:45:39 +0000 (19:45 +0000)
contrib/package/freifunk-gwcheck/Makefile
contrib/package/freifunk-gwcheck/root/etc/uci-defaults/freifunk-gwcheck

index 4922c23..ddadc05 100644 (file)
@@ -15,7 +15,7 @@ define Package/freifunk-gwcheck
   CATEGORY:=LuCI
   SUBMENU:=Freifunk
   TITLE:=Freifunk gateway check script
-  DEPENDS:=+firewall +ip +iptables-mod-ipopt
+  DEPENDS:=+firewall +ip +iptables-mod-ipopt +olsrd-mod-dyn-gw-plain
 endef
 
 define Package/freifunk-gwcheck/description
index e0574e6..e04faa5 100644 (file)
@@ -1,6 +1,6 @@
 #!/bin/sh
 tables="/etc/iproute2/rt_tables"
-[ -z "`grep -q "gw-check" $tables`" ] && echo "200 gw-check" >> $tables
+grep -q "gw-check" $tables || echo "200 gw-check" >> $tables
 test -f /etc/crontabs/root || touch /etc/crontabs/root
-[ -z "`grep -q "ff_olsr_test_gw.sh" /etc/crontabs/root`" ] && echo "* * * * *  /usr/sbin/ff_olsr_test_gw.sh" >> /etc/crontabs/root
+grep -q "ff_olsr_test_gw.sh" /etc/crontabs/root || echo "* * * * *     /usr/sbin/ff_olsr_test_gw.sh" >> /etc/crontabs/root
 /etc/init.d/cron restart