Add default compile target & use it for bridge and busybox
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Apr 2006 10:03:46 +0000 (10:03 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Apr 2006 10:03:46 +0000 (10:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3693 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/bridge/Makefile
package/busybox/Makefile
package/rules.mk

index 18ea1dd..bd71165 100644 (file)
@@ -29,10 +29,6 @@ define Build/Configure
 $(call Build/Configure/Default,--with-linux-headers=$(LINUX_DIR))
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
-endef
-
 define Package/busybox/install
        mkdir -p $(IDIR_BRIDGE)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/brctl/brctl $(IDIR_BRIDGE)/usr/sbin/
index 812e12a..3f061b8 100644 (file)
@@ -30,15 +30,6 @@ define Build/Configure
        yes '' | $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" -C $(PKG_BUILD_DIR) oldconfig
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
-               CROSS="$(TARGET_CROSS)" \
-               PREFIX="$(IDIR_BUSYBOX)" \
-               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
-               ARCH="$(ARCH)" 
-endef
-
 define Package/busybox/install
        $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" PREFIX="$(1)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) install
index 916bb0f..17f6c61 100644 (file)
@@ -213,7 +213,13 @@ define Build/Configure
 endef
 
 define Build/Compile/Default
-# TODO: add configurable default command
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               CROSS="$(TARGET_CROSS)" \
+               PREFIX="$$(IDIR_$(1))" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               ARCH="$(ARCH)" \
+               DESTDIR="$$(IDIR_$(1))"
 endef
 
 define Build/Compile