projects
/
15.05
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
136d504
)
linux: modules: crypto: adds ccm package
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 29 Mar 2015 05:20:50 +0000
(
05:20
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 29 Mar 2015 05:20:50 +0000
(
05:20
+0000)
This patch adds support crypto-ccm modules support.
Signed-off-by: Varka Bhadram <varkab@cdac.in>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45123
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index
d1ae061
..
7d47aed
100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-316,6
+316,17
@@
endef
$(eval $(call KernelPackage,crypto-ctr))
+define KernelPackage/crypto-ccm
+ TITLE:=Support for Counter with CBC MAC (CCM)
+ DEPENDS:=+kmod-crypto-ctr +kmod-crypto-aead
+ KCONFIG:=CONFIG_CRYPTO_CCM
+ FILES:=$(LINUX_DIR)/crypto/ccm.ko
+ AUTOLOAD:=$(call AutoLoad,09,ccm)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ccm))
+
define KernelPackage/crypto-pcbc
TITLE:=Propagating Cipher Block Chaining CryptoAPI module
DEPENDS:=+kmod-crypto-manager