modules/sound: cleanup by removing unsupported Kernel cases
authorJohn Crispin <blogic@openwrt.org>
Sat, 23 May 2015 15:28:36 +0000 (15:28 +0000)
committerJohn Crispin <blogic@openwrt.org>
Sat, 23 May 2015 15:28:36 +0000 (15:28 +0000)
Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45735 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/sound.mk

index 54bc30a..3cf9834 100644 (file)
@@ -32,21 +32,11 @@ SOUNDCORE_FILES ?= \
        $(LINUX_DIR)/sound/core/oss/snd-pcm-oss.ko \
        $(LINUX_DIR)/sound/core/snd-compress.ko
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
 SOUNDCORE_LOAD += \
        $(if $(CONFIG_SND_DMAENGINE_PCM),snd-pcm-dmaengine)
 
 SOUNDCORE_FILES += \
        $(if $(CONFIG_SND_DMAENGINE_PCM),$(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko)
-endif
-
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.14.0)),1)
-SOUNDCORE_LOAD += \
-       snd-page-alloc
-
-SOUNDCORE_FILES += \
-       $(LINUX_DIR)/sound/core/snd-page-alloc.ko
-endif
 
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)