remove unused wget menuconfig option; make the package autorebuild optional (but...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Jun 2006 16:17:56 +0000 (16:17 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Jun 2006 16:17:56 +0000 (16:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3896 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
package/rules.mk

index 4a887cc..740205e 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -21,10 +21,12 @@ menuconfig DEVEL
 menuconfig BUILDOPTS
        bool "Build Options" if DEVEL
 
-config WGET
-        string
-       prompt "WGET command" if BUILDOPTS
-        default "wget --passive-ftp -nd"
+config AUTOREBUILD
+       bool
+       prompt "Automatic rebuild of packages" if BUILDOPTS
+       default y
+       help
+               Automatically rebuild packages when their files change
 
 config TAR_VERBOSITY
        bool 
index 1fd6f2a..c05333b 100644 (file)
@@ -7,12 +7,16 @@ endif
 define Build/DefaultTargets
   ifeq ($(DUMP),)
     ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
-      $(PKG_BUILD_DIR)/.prepared: package-clean
+         ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.prepared: package-clean
+      endif
     endif
 
     ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
-      $(PKG_BUILD_DIR)/.built: package-rebuild
-    endif
+         ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.built: package-rebuild
+      endif
+       endif
   endif
 
   $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)