kernel: update linux 3.8 to 3.8.10
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 Apr 2013 10:43:59 +0000 (10:43 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 Apr 2013 10:43:59 +0000 (10:43 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36493 3c298f89-4303-0410-b956-a3cf2f4a3e73

28 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.8/617-MIPS-ath79-add-Netgear-WNR2000v3-support.patch
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/ep93xx/Makefile
target/linux/lantiq/Makefile
target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/generic/target.mk
target/linux/xburst/Makefile

index 9bcbd0b..b9a6776 100644 (file)
@@ -11,8 +11,8 @@ endif
 ifeq ($(LINUX_VERSION),3.7.10)
   LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
 endif
-ifeq ($(LINUX_VERSION),3.8.9)
-  LINUX_KERNEL_MD5SUM:=b5286ad3d8a729e9ae48b26211e05aec
+ifeq ($(LINUX_VERSION),3.8.10)
+  LINUX_KERNEL_MD5SUM:=3d5fb6d9add9cce7725bbe9b139c8d6e
 endif
 
 # disable the md5sum check for unknown kernel versions
index ac33719..3b50ba0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 7e24715..baaccda 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 0b9c1ef..aa3edf0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -119,6 +119,7 @@ enum ath79_mach_type {
+@@ -120,6 +120,7 @@ enum ath79_mach_type {
        ATH79_MACH_WNDR3700,            /* NETGEAR WNDR3700/WNDR3800/WNDRMAC */
        ATH79_MACH_WNDR4300,            /* NETGEAR WNDR4300 */
        ATH79_MACH_WNR2000,             /* NETGEAR WNR2000 */
@@ -28,7 +28,7 @@
        select SOC_AR724X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -100,6 +100,7 @@ obj-$(CONFIG_ATH79_MACH_WLAE_AG300N)       += 
+@@ -101,6 +101,7 @@ obj-$(CONFIG_ATH79_MACH_WLAE_AG300N)       +=
  obj-$(CONFIG_ATH79_MACH_WNDR3700)     += mach-wndr3700.o
  obj-$(CONFIG_ATH79_MACH_WNDR4300)     += mach-wndr4300.o
  obj-$(CONFIG_ATH79_MACH_WNR2000)      += mach-wnr2000.o
index ea72b67..38e2b03 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz ext2 usb
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 4caff66..f0c1345 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index b4d2b04..38948ce 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 52e4524..09410b5 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index a5a90ff..a33c61d 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 87f6c44..1542223 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 7257720..0b36548 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 DEVICE_TYPE:=developerboard
 
index 88f12b1..bcd0ff7 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index ee5fa73..16da438 100644 (file)
@@ -25,7 +25,7 @@ Subject: [PATCH 19/25] owrt mtd split
        ---help---
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -844,6 +844,168 @@ static int refresh_rootfs_split(struct m
+@@ -833,6 +833,168 @@ static int refresh_rootfs_split(struct m
  }
  #endif /* CONFIG_MTD_ROOTFS_SPLIT */
  
@@ -194,7 +194,7 @@ Subject: [PATCH 19/25] owrt mtd split
  /*
   * This function, given a master MTD object and a partition table, creates
   * and registers slave MTD objects which are bound to the master according to
-@@ -860,7 +1022,7 @@ int add_mtd_partitions(struct mtd_info *
+@@ -849,7 +1011,7 @@ int add_mtd_partitions(struct mtd_info *
        struct mtd_part *slave;
        uint64_t cur_offset = 0;
        int i;
@@ -203,7 +203,7 @@ Subject: [PATCH 19/25] owrt mtd split
        int ret;
  #endif
  
-@@ -877,6 +1039,15 @@ int add_mtd_partitions(struct mtd_info *
+@@ -866,6 +1028,15 @@ int add_mtd_partitions(struct mtd_info *
  
                add_mtd_device(&slave->mtd);
  
index 8db4e90..5e4d2c1 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 DEVICE_TYPE:=developerboard
 
index 7493441..94fe5f7 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index bb6f698..7b5a7ac 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 88d9b95..3129d18 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index fcb604a..b6f917f 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index ab79d7c..adc0193 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 0a5533c..fceccdf 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 1b359ad..f4a4212 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 8f6899c..f15d16f 100644 (file)
@@ -25,7 +25,7 @@ Subject: [PATCH 19/25] owrt mtd split
        ---help---
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -844,6 +844,99 @@ static int refresh_rootfs_split(struct m
+@@ -833,6 +833,99 @@ static int refresh_rootfs_split(struct m
  }
  #endif /* CONFIG_MTD_ROOTFS_SPLIT */
  
@@ -125,7 +125,7 @@ Subject: [PATCH 19/25] owrt mtd split
  /*
   * This function, given a master MTD object and a partition table, creates
   * and registers slave MTD objects which are bound to the master according to
-@@ -860,7 +953,7 @@ int add_mtd_partitions(struct mtd_info *
+@@ -849,7 +942,7 @@ int add_mtd_partitions(struct mtd_info *
        struct mtd_part *slave;
        uint64_t cur_offset = 0;
        int i;
@@ -134,7 +134,7 @@ Subject: [PATCH 19/25] owrt mtd split
        int ret;
  #endif
  
-@@ -877,6 +970,14 @@ int add_mtd_partitions(struct mtd_info *
+@@ -866,6 +959,14 @@ int add_mtd_partitions(struct mtd_info *
  
                add_mtd_device(&slave->mtd);
  
index 56b2d20..5244181 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index cc6d977..ce5571f 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 DEVICE_TYPE:=developerboard
 
index 3be431a..c906654 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 534ffa3..ff4c29d 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index 4e5f373..765d708 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME:=Generic
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 define Target/Description
        Build firmware images for x86 based boards
index 074f054..f90c8ec 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio broken
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 DEVICE_TYPE=other