[package/libs/libpcap]: IPv6 support should depend on if we've enabled it
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Oct 2013 11:03:00 +0000 (11:03 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Oct 2013 11:03:00 +0000 (11:03 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38349 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/libpcap/Makefile

index f1d2872..24b07c9 100644 (file)
@@ -54,7 +54,6 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-yydebug \
-       --enable-ipv6 \
        --with-build-cc="$(HOSTCC)" \
        --with-pcap=linux \
        --without-septel \
@@ -62,6 +61,11 @@ CONFIGURE_ARGS += \
        --without-libnl \
        --disable-can
 
+ifeq ($(CONFIG_IPV6),y)
+CONFIGURE_ARGS += \
+       --enable-ipv6
+endif
+
 MAKE_FLAGS += \
        CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include"