ar71xx: image: show size limit in warning messages
authorGabor Juhos <juhosg@openwrt.org>
Thu, 23 Jan 2014 12:27:28 +0000 (12:27 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 23 Jan 2014 12:27:28 +0000 (12:27 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39376 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index e9ffd77..64cd854 100644 (file)
@@ -142,9 +142,9 @@ define CatFiles
                        rm -f $(5); \
                fi; \
        else if [ $(2) -gt 262144 -a `stat -c%s "$(1)"` -gt $(2) ]; then \
-               echo "Warning: $(1) is too big" >&2; \
+               echo "Warning: $(1) is too big (> $(2) bytes)" >&2; \
        else if [ `stat -c%s $(3)` -gt $(4) ]; then \
-               echo "Warning: $(3) is too big" >&2; \
+               echo "Warning: $(3) is too big (> $(4) bytes)" >&2; \
        else \
                ( dd if=$(1) bs=$(2) conv=sync; dd if=$(3) ) > $(5); \
        fi; fi; fi