include/kernel.mk: add KernelPackage/conffiles macro
authorNicolas Thill <nico@openwrt.org>
Thu, 2 Apr 2015 14:53:34 +0000 (14:53 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 2 Apr 2015 14:53:34 +0000 (14:53 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45245 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index e3ad697..700736f 100644 (file)
@@ -157,6 +157,12 @@ define KernelPackage
     $(call KernelPackage/$(1)/$(BOARD))
   endef
 
+  ifdef KernelPackage/$(1)/conffiles
+    define Package/kmod-$(1)/conffiles
+$(call KernelPackage/$(1)/conffiles)
+    endef
+  endif
+
   ifdef KernelPackage/$(1)/description
     define Package/kmod-$(1)/description
 $(call KernelPackage/$(1)/description)