package/grub: fix build issues under 64bit FreeBSD
authorAlexandros C. Couloumbis <alex@ozo.com>
Thu, 30 Sep 2010 14:48:31 +0000 (14:48 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Thu, 30 Sep 2010 14:48:31 +0000 (14:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23162 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/grub/Makefile

index f3dd171..ee527be 100644 (file)
@@ -37,10 +37,6 @@ MY_CONFIGURE_ARGS += \
        --disable-hercules \
        --without-curses \
 
-ifeq ($(HOST_OS),FreeBSD)
-  MY_CONFIGURE_ARGS += --build=$(GNU_HOST_NAME) --host=$(GNU_TARGET_NAME) --target=$(GNU_TARGET_NAME)
-endif
-
 MY_CONFIGURE_VARS += \
        grub_cv_prog_objcopy_absolute=yes \
 
@@ -53,6 +49,14 @@ ifeq ($(HOST_OS),Darwin)
   HOST_CFLAGS += $(call host-cc-option,-fnested-functions)
 endif
 
+ifeq ($(HOST_OS),FreeBSD)
+  ifeq ($(HOST_ARCH),amd64)
+    HOST_CFLAGS += $(call host-cc-option,-m32)
+    HOST_CFLAGS += $(call host-cc-option,-B/usr/lib32)
+    HOST_CFLAGS += $(call host-cc-option,-L/usr/lib32)
+  endif
+endif
+
 HOST_CFLAGS += $(call host-cc-option,-fno-stack-protector)
 HOST_CFLAGS += $(call host-cc-option,-U_FORTIFY_SOURCE)