dante: fix broken configure script not using CFLAGS for conftest
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Feb 2013 17:22:55 +0000 (17:22 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Feb 2013 17:22:55 +0000 (17:22 +0000)
Spotted by doing an ARM hard float build.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35685 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/dante/Makefile

index 90768ad..cdd472b 100644 (file)
@@ -28,6 +28,9 @@ CONFIGURE_ARGS += \
        --without-pam \
        --disable-libwrap
 
+CONFIGURE_VARS += \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS)"
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/