FreeSWITCH: Fix dependency on LZMA issue and sync to FS latest git HEAD
authorMazilo <openwrt.mazilo@recursor.net>
Fri, 16 Aug 2013 19:24:15 +0000 (15:24 -0400)
committerMazilo <openwrt.mazilo@recursor.net>
Fri, 16 Aug 2013 19:24:15 +0000 (15:24 -0400)
1. The FS libs/tiff package can make use of liblzma if avaialable. This
fix reverts commit bff1f87ad70cd80456a9b6c77f1120141a7aea61. It
checks the CONFIG_PACKAGE_liblzma variable to determine liblzma
and will either pass --enable-lzma or --disable-lzma switch to
configure. For mod-spandsp, +liblzma:liblzma automatically sets
the liblzma dependency flag.
2. Synched to FS git HEAD d35db852a8bcc4fb10e7a8486046aabd45a7f9b2.

Signed-off-by: Mazilo <openwrt.mazilo@recursor.net>
net/freeswitch/Makefile

index bfef2e0..28f3411 100644 (file)
@@ -19,7 +19,7 @@ PKG_VERSION:=1.5.5b
 # http://fisheye.freeswitch.org
 #
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
-FS_DEFAULT_HEAD:=451aece80391bf08bc0e8b25fce2e2cb4f88bc41
+FS_DEFAULT_HEAD:=d35db852a8bcc4fb10e7a8486046aabd45a7f9b2
 FS_LATEST_HEAD:=$(if $(DUMP),$(FS_DEFAULT_HEAD),$(shell git ls-remote $(PKG_SOURCE_URL) HEAD | cut -f1))
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_WITH_PULL_CURRENT),$(FS_LATEST_HEAD),$(FS_DEFAULT_HEAD))
 PKG_SOURCE_VERSION_SHORT:=$(shell echo $(PKG_SOURCE_VERSION)|cut -b -7)
@@ -169,7 +169,6 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_FS_WITH_BUILTIN_ZRTP \
        CONFIG_FS_WITH_FIXED_POINT \
        CONFIG_FS_WITH_IPV6 \
-       CONFIG_FS_WITH_LZMA \
        CONFIG_FS_WITH_MYSQL \
        CONFIG_FS_WITH_ODBC \
        CONFIG_FS_WITH_OPT \
@@ -247,14 +246,6 @@ define Package/$(PKG_NAME)/config
     help
        Compile libs/apr package with IPV6 support.
 
-    config FS_WITH_LZMA
-    depends on PACKAGE_$(PKG_NAME) && PACKAGE_liblzma
-    bool "Enable liblzma usage in libtiff"
-    default y
-    help
-       Compile libs/tiff package with liblzma support. This option requires
-       LZMA2 compression package called liblzma.
-
     config FS_WITH_OPT
     depends on PACKAGE_$(PKG_NAME)
     bool "Enable optimization"
@@ -605,7 +596,7 @@ CONFIGURE_ARGS+= \
        $(if ($(CONFIG_PACKAGE_$(PKG_NAME)-mod-curl)|$(CONFIG_PACKAGE_$(PKG_NAME)-mod-xml-cdr)|$(CONFIG_PACKAGE_$(PKG_NAME)-mod-xml-curl)),--with-libcurl="$(STAGING_DIR)/usr",--without-libcurl) \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-erlang-event),--with,--without)-erlang \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-java),--with-java="$(STAGING_DIR)/usr",--without-java) \
-       $(call autoconf_bool,CONFIG_FS_WITH_LZMA,lzma) \
+       $(call autoconf_bool,CONFIG_PACKAGE_liblzma,lzma) \
        $(call autoconf_bool,CONFIG_FS_WITH_POSTGRESQL,core-pgsql-support) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-spandsp && CONFIG_FS_WITH_FIXED_POINT,fixed-point) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-spandsp,builtin-tiff) \
@@ -1079,7 +1070,7 @@ $(eval $(call BuildPlugin,snmp,SNMP AgentX Subagent,vanilla,,,,+libnetsnmp))
 $(eval $(call BuildPlugin,snom,SNOM specific features,vanilla,,,,))
 $(eval $(call BuildPlugin,sofia,SOFIA SIP,mod,,,,)) # ~/conf
 $(eval $(call BuildPlugin,sonar,Sonar Ping Timer,vanilla,,,,))
-$(eval $(call BuildPlugin,spandsp,Span DSP,mod,,,,+libjpeg)) # ~/conf
+$(eval $(call BuildPlugin,spandsp,Span DSP,mod,,,,+libjpeg +liblzma:liblzma)) # ~/conf
 $(eval $(call BuildPlugin,speex,Speex codec,mod,,,,))
 $(eval $(call BuildPlugin,spidermonkey,JavaScript,vanilla,,,,@BROKEN)) # fails in js
 $(eval $(call BuildPlugin,spidermonkey-core_db,JavaScript DB,vanilla,,,,@BROKEN))