iwinfo: don't use the txpower value from debugfs for now, it does not match the value...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Jan 2013 14:08:08 +0000 (14:08 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Jan 2013 14:08:08 +0000 (14:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35007 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iwinfo/Makefile
package/network/utils/iwinfo/src/iwinfo_nl80211.c

index 0bea4ec..479dcb5 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=37
+PKG_RELEASE:=38
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index ae75e6d..819845a 100644 (file)
@@ -993,6 +993,7 @@ int nl80211_get_channel(const char *ifname, int *buf)
 
 int nl80211_get_txpower(const char *ifname, int *buf)
 {
+#if 0
        char *res;
        char path[PATH_MAX];
 
@@ -1002,6 +1003,7 @@ int nl80211_get_txpower(const char *ifname, int *buf)
 
        if ((*buf = nl80211_readint(path)) > -1)
                return 0;
+#endif
 
        return wext_get_txpower(ifname, buf);
 }