include: Allow git kernel branch selection
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:45:22 +0000 (12:45 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:45:22 +0000 (12:45 +0000)
This allows the selection of a specific branch in the menuconfig
when using a kernel downloaded from GIT.

Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40946 3c298f89-4303-0410-b956-a3cf2f4a3e73

config/Config-devel.in
include/kernel-defaults.mk

index fd57bcb..0931175 100644 (file)
@@ -62,6 +62,24 @@ menuconfig DEVEL
                  This will create a git clone of the kernel in your build
                  directory.
 
+       config KERNEL_GIT_LOCAL_REPOSITORY
+               string "Enter path to local reference repository" if DEVEL
+               depends on (KERNEL_GIT_CLONE_URI != "")
+               default ""
+               help
+                 Enter a full pathname to a local reference git repository.
+                 In this instance, the --refererence option of git clone will
+                 be used thus creating a quick local clone of your repo.
+
+       config KERNEL_GIT_BRANCH
+               string "Enter git branch to clone" if DEVEL
+               depends on (KERNEL_GIT_CLONE_URI != "")
+               default ""
+               help
+                 Enter the branch name to checkout after cloning the git repository.
+                 In this instance, the --branch option of git clone will be used.
+                 If unused, the clone's repository HEAD will be checked-out.
+
        config BUILD_LOG
                bool "Enable log files during build process" if DEVEL
                help
index fd75a3f..f1f5a81 100644 (file)
@@ -38,6 +38,10 @@ ifneq ($(strip $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)),"")
   KERNEL_GIT_OPTS+=--reference $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)
 endif
 
+ifneq ($(strip $(CONFIG_KERNEL_GIT_BRANCH)),"")
+  KERNEL_GIT_OPTS+=--branch $(CONFIG_KERNEL_GIT_BRANCH)
+endif
+
 ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
   ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
     define Kernel/Prepare/Default