generic: bump 4.4 to rc4
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Dec 2015 10:11:43 +0000 (10:11 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Dec 2015 10:11:43 +0000 (10:11 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47801 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/config-4.4
target/linux/generic/patches-4.4/010-net-remove-unnecessary-semicolon-in-netdev_alloc_pcp.patch
target/linux/generic/patches-4.4/103-packet_allow_empty_payload.patch [deleted file]
target/linux/generic/patches-4.4/143-mtd-bcm47xxpart-limit-scanned-flash-area-on-BCM47XX-.patch
target/linux/generic/patches-4.4/144-mtd-bcm47xxpart-don-t-fail-because-of-bit-flips.patch
target/linux/generic/patches-4.4/662-use_fq_codel_by_default.patch
target/linux/generic/patches-4.4/664-codel_fix_3_12.patch
target/linux/generic/patches-4.4/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/patches-4.4/721-phy_packets.patch
target/linux/generic/patches-4.4/902-debloat_proc.patch

index c856296..201c2a9 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .23
 LINUX_VERSION-4.1 = .13
 LINUX_VERSION-4.3 =
-LINUX_VERSION-4.4 = -rc3
+LINUX_VERSION-4.4 = -rc4
 
 LINUX_KERNEL_MD5SUM-3.18.23 = dc6d265ab38716be3676ac294b481ad8
 LINUX_KERNEL_MD5SUM-4.1.13 = af9dd5d8f71185a64a8eccface15fc00
 LINUX_KERNEL_MD5SUM-4.3 = 58b35794eee3b6d52ce7be39357801e7
-LINUX_KERNEL_MD5SUM-4.4-rc3 = e1d3a425a135654c6d2cbc4547e287ee
+LINUX_KERNEL_MD5SUM-4.4-rc4 = 893caa049cd5c680bf6770603d6cb416
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 7b94b3a..25a8d1b 100644 (file)
@@ -235,10 +235,12 @@ CONFIG_ARCH_FLATMEM_ENABLE=y
 # CONFIG_ARM_APPENDED_DTB is not set
 # CONFIG_ARM_ARCH_TIMER is not set
 # CONFIG_ARM_AT91_ETHER is not set
+# CONFIG_ARM_BIG_LITTLE_CPUFREQ is not set
 # CONFIG_ARM_CCI is not set
 # CONFIG_ARM_CCI400_PMU is not set
 # CONFIG_ARM_CCN is not set
 CONFIG_ARM_CPU_TOPOLOGY=y
+# CONFIG_ARM_CPUIDLE is not set
 # CONFIG_ARM_CRYPTO is not set
 CONFIG_ARM_DMA_MEM_BUFFERABLE=y
 # CONFIG_ARM_ERRATA_326103 is not set
@@ -338,6 +340,7 @@ CONFIG_ATM_CLIP_NO_ICMP=y
 # CONFIG_AUDIT is not set
 # CONFIG_AUDIT_ARCH_COMPAT_GENERIC is not set
 # CONFIG_AUDIT_LOGINUID_IMMUTABLE is not set
+# CONFIG_AURORA_NB8800 is not set
 # CONFIG_AUTOFS4_FS is not set
 # CONFIG_AUTO_ZRELADDR is not set
 # CONFIG_AUXDISPLAY is not set
@@ -1668,6 +1671,7 @@ CONFIG_INPUT_MISC=y
 # CONFIG_INPUT_YEALINK is not set
 # CONFIG_INT340X_THERMAL is not set
 # CONFIG_INTEL_IDLE is not set
+# CONFIG_INTEL_IDMA64 is not set
 # CONFIG_INTEL_MEI is not set
 # CONFIG_INTEL_MEI_ME is not set
 # CONFIG_INTEL_MEI_TXE is not set
@@ -1960,6 +1964,7 @@ CONFIG_LEDS_GPIO_PLATFORM=y
 # CONFIG_LEDS_LP8860 is not set
 # CONFIG_LEDS_LT3593 is not set
 # CONFIG_LEDS_NET5501 is not set
+# CONFIG_LEDS_NS2 is not set
 # CONFIG_LEDS_OT200 is not set
 # CONFIG_LEDS_PCA9532 is not set
 # CONFIG_LEDS_PCA955X is not set
@@ -2687,6 +2692,7 @@ CONFIG_NET_VENDOR_AGERE=y
 CONFIG_NET_VENDOR_ALTEON=y
 CONFIG_NET_VENDOR_AMD=y
 CONFIG_NET_VENDOR_ARC=y
+CONFIG_NET_VENDOR_AURORA=y
 CONFIG_NET_VENDOR_ATHEROS=y
 CONFIG_NET_VENDOR_BROADCOM=y
 CONFIG_NET_VENDOR_BROCADE=y
@@ -3361,6 +3367,7 @@ CONFIG_RTC_DRV_CMOS=y
 # CONFIG_RTC_DRV_RS5C372 is not set
 # CONFIG_RTC_DRV_RTC7301 is not set
 # CONFIG_RTC_DRV_RV3029C2 is not set
+# CONFIG_RTC_DRV_RV8803 is not set
 # CONFIG_RTC_DRV_RX4581 is not set
 # CONFIG_RTC_DRV_RX8025 is not set
 # CONFIG_RTC_DRV_RX8581 is not set
@@ -4045,6 +4052,7 @@ CONFIG_SND_VERBOSE_PROCFS=y
 # CONFIG_SNI_RM is not set
 # CONFIG_SOC_AM33XX is not set
 # CONFIG_SOC_AM43XX is not set
+# CONFIG_SOC_BRCMSTB is not set
 # CONFIG_SOC_CAMERA is not set
 # CONFIG_SOC_DRA7XX is not set
 # CONFIG_SOC_HAS_OMAP2_SDRC is not set
@@ -4231,8 +4239,11 @@ CONFIG_TEXTSEARCH=y
 # CONFIG_TEXTSEARCH_FSM is not set
 # CONFIG_TEXTSEARCH_KMP is not set
 # CONFIG_THERMAL is not set
+# CONFIG_THERMAL_DEFAULT_GOV_POWER_ALLOCATOR is not set
 # CONFIG_THERMAL_GOV_BANG_BANG is not set
+# CONFIG_THERMAL_GOV_POWER_ALLOCATOR is not set
 # CONFIG_THERMAL_HWMON is not set
+# CONFIG_THERMAL_WRITABLE_TRIPS is not set
 # CONFIG_THINKPAD_ACPI is not set
 # CONFIG_THRUSTMASTER_FF is not set
 # CONFIG_THUNDERBOLT is not set
@@ -4347,6 +4358,7 @@ CONFIG_TTY=y
 # CONFIG_TWL6040_CORE is not set
 # CONFIG_TYPHOON is not set
 # CONFIG_UACCESS_WITH_MEMCPY is not set
+# CONFIG_UBIFS_ATIME_SUPPORT is not set
 # CONFIG_UCB1400_CORE is not set
 # CONFIG_UDF_FS is not set
 CONFIG_UDF_NLS=y
index 7123599..b8b9a83 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -2083,7 +2083,7 @@ struct pcpu_sw_netstats {
+@@ -2084,7 +2084,7 @@ struct pcpu_sw_netstats {
  })
  
  #define netdev_alloc_pcpu_stats(type)                                 \
diff --git a/target/linux/generic/patches-4.4/103-packet_allow_empty_payload.patch b/target/linux/generic/patches-4.4/103-packet_allow_empty_payload.patch
deleted file mode 100644 (file)
index ce37d5b..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix a regression in the af_packet code that was breaking PPPoE
-
-pppd sends packets with only a header and no payload.
-
-Signed-off-by: Felix Fietkau <nbd@openwrt.org>
-
---- a/net/packet/af_packet.c
-+++ b/net/packet/af_packet.c
-@@ -2329,7 +2329,7 @@ static void tpacket_destruct_skb(struct
- static bool ll_header_truncated(const struct net_device *dev, int len)
- {
-       /* net device doesn't like empty head */
--      if (unlikely(len <= dev->hard_header_len)) {
-+      if (unlikely(len < dev->hard_header_len)) {
-               net_warn_ratelimited("%s: packet size is too short (%d <= %d)\n",
-                                    current->comm, len, dev->hard_header_len);
-               return true;
index aa31514..761cff3 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 
 --- a/drivers/mtd/bcm47xxpart.c
 +++ b/drivers/mtd/bcm47xxpart.c
-@@ -118,8 +118,8 @@ static int bcm47xxpart_parse(struct mtd_info *master,
+@@ -118,8 +118,8 @@ static int bcm47xxpart_parse(struct mtd_
        /* Parse block by block looking for magics */
        for (offset = 0; offset <= master->size - blocksize;
             offset += blocksize) {
index f9e81f9..9073f79 100644 (file)
@@ -14,11 +14,9 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
  drivers/mtd/bcm47xxpart.c | 38 ++++++++++++++++++++++----------------
  1 file changed, 22 insertions(+), 16 deletions(-)
 
-diff --git a/drivers/mtd/bcm47xxpart.c b/drivers/mtd/bcm47xxpart.c
-index 4450e74..1ab3451 100644
 --- a/drivers/mtd/bcm47xxpart.c
 +++ b/drivers/mtd/bcm47xxpart.c
-@@ -66,11 +66,13 @@ static const char *bcm47xxpart_trx_data_part_name(struct mtd_info *master,
+@@ -66,11 +66,13 @@ static const char *bcm47xxpart_trx_data_
  {
        uint32_t buf;
        size_t bytes_read;
@@ -36,7 +34,7 @@ index 4450e74..1ab3451 100644
                goto out_default;
        }
  
-@@ -95,6 +97,7 @@ static int bcm47xxpart_parse(struct mtd_info *master,
+@@ -95,6 +97,7 @@ static int bcm47xxpart_parse(struct mtd_
        int trx_part = -1;
        int last_trx_part = -1;
        int possible_nvram_sizes[] = { 0x8000, 0xF000, 0x10000, };
@@ -44,7 +42,7 @@ index 4450e74..1ab3451 100644
  
        /*
         * Some really old flashes (like AT45DB*) had smaller erasesize-s, but
-@@ -128,10 +131,11 @@ static int bcm47xxpart_parse(struct mtd_info *master,
+@@ -128,10 +131,11 @@ static int bcm47xxpart_parse(struct mtd_
                }
  
                /* Read beginning of the block */
@@ -60,7 +58,7 @@ index 4450e74..1ab3451 100644
                        continue;
                }
  
-@@ -254,10 +258,11 @@ static int bcm47xxpart_parse(struct mtd_info *master,
+@@ -254,10 +258,11 @@ static int bcm47xxpart_parse(struct mtd_
                }
  
                /* Read middle of the block */
@@ -76,7 +74,7 @@ index 4450e74..1ab3451 100644
                        continue;
                }
  
-@@ -277,10 +282,11 @@ static int bcm47xxpart_parse(struct mtd_info *master,
+@@ -277,10 +282,11 @@ static int bcm47xxpart_parse(struct mtd_
                }
  
                offset = master->size - possible_nvram_sizes[i];
@@ -92,6 +90,3 @@ index 4450e74..1ab3451 100644
                        continue;
                }
  
--- 
-1.8.4.5
-
index fba373a..4ba20be 100644 (file)
@@ -32,7 +32,7 @@
  {
 --- a/include/net/sch_generic.h
 +++ b/include/net/sch_generic.h
-@@ -341,6 +341,7 @@ extern struct Qdisc_ops noop_qdisc_ops;
+@@ -344,6 +344,7 @@ extern struct Qdisc_ops noop_qdisc_ops;
  extern struct Qdisc_ops pfifo_fast_ops;
  extern struct Qdisc_ops mq_qdisc_ops;
  extern struct Qdisc_ops noqueue_qdisc_ops;
index 838c9f6..2682441 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -1936,7 +1936,7 @@ static int __init pktsched_init(void)
+@@ -1945,7 +1945,7 @@ static int __init pktsched_init(void)
                return err;
        }
  
index cdac78c..921b809 100644 (file)
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        return 0;
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1637,6 +1637,8 @@ struct net_device {
+@@ -1638,6 +1638,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
index 0816508..719275b 100644 (file)
@@ -16,7 +16,7 @@
  
  /**
   *    struct net_device - The DEVICE structure.
-@@ -1602,6 +1604,11 @@ struct net_device {
+@@ -1603,6 +1605,11 @@ struct net_device {
        const struct l3mdev_ops *l3mdev_ops;
  #endif
  
@@ -28,7 +28,7 @@
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1668,6 +1675,10 @@ struct net_device {
+@@ -1669,6 +1676,10 @@ struct net_device {
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
index 1111c21..2d7cc5d 100644 (file)
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3038,6 +3038,8 @@ static __net_initdata struct pernet_oper
+@@ -3036,6 +3036,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {