Added libcli, l2tpns, fixed typo and mising URL
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2005 13:23:40 +0000 (13:23 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2005 13:23:40 +0000 (13:23 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2669 3c298f89-4303-0410-b956-a3cf2f4a3e73

13 files changed:
package/Config.in
package/Makefile
package/l2tpns/Config.in [new file with mode: 0644]
package/l2tpns/Makefile [new file with mode: 0755]
package/l2tpns/ipkg/l2tpns.control [new file with mode: 0755]
package/l2tpns/patches/01-honor_includes_remove_backtrace.patch [new file with mode: 0644]
package/libcli/Config.in [new file with mode: 0644]
package/libcli/Makefile [new file with mode: 0755]
package/libcli/ipkg/libcli.control [new file with mode: 0755]
package/libcli/patches/01-remove_debug_honor_prefix.patch [new file with mode: 0644]
package/vgp/Config.in
package/vnc-reflector/Config.in
package/wccpd/Config.in

index 51e3e5e..aa91d43 100644 (file)
@@ -78,6 +78,7 @@ source "package/iptraf/Config.in"
 source "package/kismet/Config.in"
 source "package/knock/Config.in"
 source "package/l2tpd/Config.in"
+source "package/l2tpns/Config.in"
 source "package/lighttpd/Config.in"
 source "package/linux-atm/Config.in"
 source "package/maradns/Config.in"
@@ -165,6 +166,7 @@ source "package/id3lib/Config.in"
 source "package/libamsel/Config.in"
 source "package/libao/Config.in"
 source "package/libart/Config.in"
+source "package/libcli/Config.in"
 source "package/curl/Config.in" # libcurl
 source "package/libdaemon/Config.in"
 source "package/libdb/Config.in"
index b4ad107..c83949f 100644 (file)
@@ -73,11 +73,13 @@ package-$(BR2_COMPILE_JPEG) += jpeg
 package-$(BR2_COMPILE_KISMET) += kismet
 package-$(BR2_COMPILE_KNOCK) += knock
 package-$(BR2_PACKAGE_L2TPD) += l2tpd
+package-$(BR2_PACKAGE_L2TPNS) += l2tpns
 package-$(BR2_PACKAGE_LCD4LINUX) += lcd4linux
 package-$(BR2_PACKAGE_LESS) += less
 package-$(BR2_PACKAGE_LIBAMSEL) += libamsel
 package-$(BR2_PACKAGE_LIBAO) += libao
 package-$(BR2_PACKAGE_LIBART) += libart
+package-$(BR2_PACKAGE_LIBCLI) += libcli
 package-$(BR2_PACKAGE_LIBDAEMON) += libdaemon
 package-$(BR2_PACKAGE_LIBDNET) += libdnet
 package-$(BR2_PACKAGE_LIBELF) += libelf
@@ -209,7 +211,7 @@ package-$(BR2_PACKAGE_UDEV) += udev
 package-$(BR2_PACKAGE_VGP) += vgp
 package_$(BR2_PACKAGE_VNC_REFLECTOR) += vnc-reflector
 package-$(BR2_PACKAGE_VPNC) += vpnc
-package-$(BR2_PACKGE_VRRPD) += vrrpd
+package-$(BR2_PACKAGE_VRRPD) += vrrpd
 package-$(BR2_PACKAGE_VTUN) += vtun
 package-$(BR2_PACKAGE_VSFTPD) += vsftpd
 package-$(BR2_PACKAGE_WCCPD) += wccpd
@@ -267,6 +269,7 @@ iptables-snmp-compile: net-snmp-compile
 iptraf-compile: ncurses-compile
 hostapd-compile: openssl-compile wireless-tools-compile
 kismet-compile: uclibc++-compile libpcap-compile ncurses-compile
+l2tpns-compile: libcli-compile
 less-compile: ncurses-compile
 lcd4linux-compile: ncurses-compile
 libgcrypt-compile: libgpg-error-compile
diff --git a/package/l2tpns/Config.in b/package/l2tpns/Config.in
new file mode 100644 (file)
index 0000000..e78b46b
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_L2TPNS
+       prompt "l2tpns............................ An L2TP enhanced server"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBCLI
+       help
+               l2tpns is a layer 2 tunneling protocol network server (LNS).
+               It supports up to 65535 concurrent sessions per server/cluster 
+               plus ISP features such as rate limiting, walled garden, usage 
+               accounting, and more.
+
+               http://sourceforge.net/projects/l2tpns
diff --git a/package/l2tpns/Makefile b/package/l2tpns/Makefile
new file mode 100755 (executable)
index 0000000..6f2406e
--- /dev/null
@@ -0,0 +1,29 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=l2tpns
+PKG_VERSION:=2.1.14
+PKG_RELEASE:=1
+PKG_MD5SUM:=2a0ee2a3678160c335f1d68c17c4f871
+PKG_SOURCE_URL:=@SF/L2TPNS
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,L2TPNS,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) CC=$(TARGET_CC) LD=$(TARGET_CC) DESTDIR=$(PKG_INSTALL_DIR) STAGING_DIR=$(STAGING_DIR) -C $(PKG_BUILD_DIR) install
+       touch $@
+
+$(IPKG_L2TPNS):
+       mkdir -p $(IDIR_L2TPNS)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_L2TPNS)/
+       $(RSTRIP) $(IDIR_L2TPNS)
+       $(IPKG_BUILD) $(IDIR_L2TPNS) $(PACKAGE_DIR)
diff --git a/package/l2tpns/ipkg/l2tpns.control b/package/l2tpns/ipkg/l2tpns.control
new file mode 100755 (executable)
index 0000000..6928c2e
--- /dev/null
@@ -0,0 +1,5 @@
+Package: l2tpns
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: l2tpns is a layer 2 tunneling protocol network server (LNS). It supports up to 65535 concurrent sessions per server/cluster plus ISP features such as rate limiting, walled garden, usage accounting, and more.
\ No newline at end of file
diff --git a/package/l2tpns/patches/01-honor_includes_remove_backtrace.patch b/package/l2tpns/patches/01-honor_includes_remove_backtrace.patch
new file mode 100644 (file)
index 0000000..a8e4d75
--- /dev/null
@@ -0,0 +1,128 @@
+diff -urN orig/l2tpns-2.1.14/Makefile l2tpns-2.1.14/Makefile
+--- orig/l2tpns-2.1.14/Makefile        2005-12-07 06:21:37.000000000 +0100
++++ l2tpns-2.1.14/Makefile     2005-12-14 12:50:49.000000000 +0100
+@@ -11,17 +11,14 @@
+ DEFINES += -DETCDIR='"$(etcdir)"'
+ OPTIM =
+-OPTIM += -g
+ OPTIM += -O3
+-CC = gcc
+-LD = gcc
+-INCLUDES = -I.
++INCLUDES = -I. -I$(STAGING_DIR)/usr/include
+ CPPFLAGS = $(INCLUDES) $(DEFINES)
+ CFLAGS = -Wall -Wformat-security -Wno-format-zero-length $(OPTIM)
+-LDFLAGS =
++LDFLAGS = -L$(STAGING_DIR)/usr/lib
+ LDLIBS =
+-INSTALL = install -c -D -o root -g root
++INSTALL = install -c -D
+ l2tpns.LIBS = -lm -lcli -ldl
+diff -urN orig/l2tpns-2.1.14/l2tpns.c l2tpns-2.1.14/l2tpns.c
+--- orig/l2tpns-2.1.14/l2tpns.c        2005-12-07 06:21:37.000000000 +0100
++++ l2tpns-2.1.14/l2tpns.c     2005-12-14 12:50:36.000000000 +0100
+@@ -940,18 +940,14 @@
+       if (!t)
+       {
+-              static int backtrace_count = 0;
+               LOG(0, 0, t, "tunnelsend called with 0 as tunnel id\n");
+               STAT(tunnel_tx_errors);
+-              log_backtrace(backtrace_count, 5)
+               return;
+       }
+       if (!tunnel[t].ip)
+       {
+-              static int backtrace_count = 0;
+               LOG(1, 0, t, "Error sending data out tunnel: no remote endpoint (tunnel not set up)\n");
+-              log_backtrace(backtrace_count, 5)
+               STAT(tunnel_tx_errors);
+               return;
+       }
+@@ -4125,23 +4121,8 @@
+               struct sched_param params = {0};
+               params.sched_priority = 1;
+-              if (get_nprocs() < 2)
+-              {
+-                      LOG(0, 0, 0, "Not using FIFO scheduler, there is only 1 processor in the system.\n");
+-                      config->scheduler_fifo = 0;
+-              }
+-              else
+-              {
+-                      if ((ret = sched_setscheduler(0, SCHED_FIFO, &params)) == 0)
+-                      {
+-                              LOG(1, 0, 0, "Using FIFO scheduler.  Say goodbye to any other processes running\n");
+-                      }
+-                      else
+-                      {
+-                              LOG(0, 0, 0, "Error setting scheduler to FIFO: %s\n", strerror(errno));
+-                              config->scheduler_fifo = 0;
+-                      }
+-              }
++              LOG(0, 0, 0, "Not using FIFO scheduler, there is only 1 processor in the system.\n");
++              config->scheduler_fifo = 0;
+       }
+       /* Set up the cluster communications port. */
+diff -urN orig/l2tpns-2.1.14/l2tpns.h l2tpns-2.1.14/l2tpns.h
+--- orig/l2tpns-2.1.14/l2tpns.h        2005-12-09 01:43:17.000000000 +0100
++++ l2tpns-2.1.14/l2tpns.h     2005-12-14 07:43:51.000000000 +0100
+@@ -5,7 +5,6 @@
+ #define __L2TPNS_H__
+ #include <netinet/in.h>
+-#include <execinfo.h>
+ #include <stdio.h>
+ #include <signal.h>
+ #include <stdlib.h>
+@@ -766,21 +765,6 @@
+ extern ippoolt *ip_address_pool;
+ #define sessionfree (session[0].next)
+-#define log_backtrace(count, max) \
+-if (count++ < max) { \
+-      void *array[20]; \
+-      char **strings; \
+-      int size, i; \
+-      LOG(0, 0, t, "Backtrace follows:\n"); \
+-      size = backtrace(array, 10); \
+-      strings = backtrace_symbols(array, size); \
+-      if (strings) for (i = 0; i < size; i++) \
+-      { \
+-              LOG(0, 0, t, " %s\n", strings[i]); \
+-      } \
+-      free(strings); \
+-}
+-
+ extern configt *config;
+ extern time_t basetime;               // Time when this process started.
+diff -urN orig/l2tpns-2.1.14/ppp.c l2tpns-2.1.14/ppp.c
+--- orig/l2tpns-2.1.14/ppp.c   2005-12-07 06:21:37.000000000 +0100
++++ l2tpns-2.1.14/ppp.c        2005-12-14 07:43:08.000000000 +0100
+@@ -1755,9 +1755,7 @@
+ {
+       if (size < 12) // Need more space than this!!
+       {
+-              static int backtrace_count = 0;
+               LOG(0, s, t, "makeppp buffer too small for L2TP header (size=%d)\n", size);
+-              log_backtrace(backtrace_count, 5)
+               return NULL;
+       }
+@@ -1780,9 +1778,7 @@
+       if (l + 12 > size)
+       {
+-              static int backtrace_count = 0;
+               LOG(2, s, t, "makeppp would overflow buffer (size=%d, header+payload=%d)\n", size, l + 12);
+-              log_backtrace(backtrace_count, 5)
+               return NULL;
+       }
diff --git a/package/libcli/Config.in b/package/libcli/Config.in
new file mode 100644 (file)
index 0000000..2fd0078
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBCLI
+       prompt "l2tpns............................ A Cisco-like command line interface
+       tristate
+       default m if CONFIG_DEVEL
+       help
+               Provides a shared library for including a Cisco-like 
+               command-line interface into other software. It's a telnet 
+               interface which supports command-line editing, history, 
+               authentication and callbacks for a user-definable function tree
+
+               http://libcli.sourceforge.net/
diff --git a/package/libcli/Makefile b/package/libcli/Makefile
new file mode 100755 (executable)
index 0000000..795a8bd
--- /dev/null
@@ -0,0 +1,30 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libcli
+PKG_VERSION:=1.8.5
+PKG_RELEASE:=1
+PKG_MD5SUM:=0fdd30df5a8c1388a4549751ba61247a
+PKG_SOURCE_URL:=@SF/libcli
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBCLI,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) CC=$(TARGET_CC) LD=$(TARGET_CC) DESTDIR=$(STAGING_DIR) -C $(PKG_BUILD_DIR) install
+       $(MAKE) CC=$(TARGET_CC) LD=$(TARGET_CC) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+       touch $@
+
+$(IPKG_LIBCLI):
+       mkdir -p $(IDIR_LIBCLI)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_LIBCLI)/
+       $(RSTRIP) $(IDIR_LIBCLI)
+       $(IPKG_BUILD) $(IDIR_LIBCLI) $(PACKAGE_DIR)
diff --git a/package/libcli/ipkg/libcli.control b/package/libcli/ipkg/libcli.control
new file mode 100755 (executable)
index 0000000..6ef456b
--- /dev/null
@@ -0,0 +1,5 @@
+Package: libcli
+Section: libs
+Architecture: mipsel
+Priority: optional
+Description: Provides a shared library for including a Cisco-like command-line interface into other software. 
\ No newline at end of file
diff --git a/package/libcli/patches/01-remove_debug_honor_prefix.patch b/package/libcli/patches/01-remove_debug_honor_prefix.patch
new file mode 100644 (file)
index 0000000..830baa0
--- /dev/null
@@ -0,0 +1,19 @@
+diff -urN orig/libcli-1.8.5/Makefile libcli-1.8.5/Makefile
+--- orig/libcli-1.8.5/Makefile 2005-05-02 11:57:39.000000000 +0200
++++ libcli-1.8.5/Makefile      2005-12-13 17:42:46.000000000 +0100
+@@ -1,13 +1,12 @@
+ DESTDIR =
+-PREFIX = /usr/local
++PREFIX = /usr/
+ MAJOR = 1
+ MINOR = 8
+ REVISION = 5
+ LIB = libcli.so
+-CC = gcc
+-DEBUG = -g
++DEBUG = 
+ OPTIM = -O3
+ CFLAGS += $(DEBUG) $(OPTIM) -Wall -Wformat-security -Wno-format-zero-length
+ LDFLAGS += -shared -Wl,-soname,$(LIB).$(MAJOR).$(MINOR)
index fb787fa..db543c3 100755 (executable)
@@ -8,4 +8,5 @@ config BR2_PACKAGE_VGP
                of Virtual Gateway to provide fault tollerance (and load
                balancing) on your net. Each client on your net has as its
                default gateway the virtual gateway and not the real router.
+
                http://vgpd.freaknet.org/
index 9d94e47..22679fc 100755 (executable)
@@ -10,3 +10,5 @@ config BR2_PACKAGE_VNC_REFLECTOR
          number of VNC clients. It was designed to work efficiently
          with large number of clients.
 
+         http://sourceforge.net/projects/vnc-reflector
+
index 33b35ec..ed219ed 100755 (executable)
@@ -7,3 +7,5 @@ config BR2_PACKAGE_WCCPD
                It allows a router (running Linux) to redirect web traffic to a
                group of Squid servers using WCCP as the monitoring/controling 
                protocol.
+
+               http://wccpd.sourceforge.net/