samba36: fix segmentation fault when trying to add non-existent users
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Feb 2013 11:39:42 +0000 (11:39 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Feb 2013 11:39:42 +0000 (11:39 +0000)
Based on a patch from НКВД. Closes #12962.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35610 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/samba36/Makefile
package/network/services/samba36/patches/111-owrt_smbpasswd.patch

index f71d909..2842c98 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=3.6.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
        http://ftp.samba.org/pub/samba/old-versions
index 25a9cb9..7d852c4 100644 (file)
 +      }
 +
 +      if (!find_passwd_line(fp, user, &p1)) {
-+              printf("User %s not found or invalid in /etc/passwd\n");
++              printf("User %s not found or invalid in /etc/passwd\n", user);
 +              goto out;
 +      }
 +