[packages_10.03.2] ptunnel: merge r29098, r29228
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 15:57:49 +0000 (15:57 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 15:57:49 +0000 (15:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30244 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ptunnel/Makefile
net/ptunnel/files/ptunnel.conf [deleted file]
net/ptunnel/files/ptunnel.config [new file with mode: 0644]
net/ptunnel/files/ptunnel.init

index 54b8b32..52e9558 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ptunnel
 PKG_VERSION:=0.71
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=PingTunnel-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.cs.uit.no/~daniels/PingTunnel
@@ -52,11 +52,11 @@ endef
 
 define Package/ptunnel/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ptunnel $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ptunnel $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ptunnel.init $(1)/etc/init.d/ptunnel
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_CONF) ./files/ptunnel.conf $(1)/etc/config/ptunnel
+       $(INSTALL_CONF) ./files/ptunnel.config $(1)/etc/config/ptunnel
 endef
 
 $(eval $(call BuildPackage,ptunnel))
diff --git a/net/ptunnel/files/ptunnel.conf b/net/ptunnel/files/ptunnel.conf
deleted file mode 100644 (file)
index bfc7495..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-config ptunnel
-       option interface 'lan'
diff --git a/net/ptunnel/files/ptunnel.config b/net/ptunnel/files/ptunnel.config
new file mode 100644 (file)
index 0000000..bfc7495
--- /dev/null
@@ -0,0 +1,2 @@
+config ptunnel
+       option interface 'lan'
index 99252d5..9524909 100644 (file)
@@ -1,40 +1,32 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 
 START=70
-BIN=ptunnel
-PIDCOUNT=0
 
-start() {
-       include /lib/network
-       scan_interfaces
-
-       config_load ptunnel
-       config_foreach start_ptunnel ptunnel
-       iptables -I OUTPUT 1 -p icmp -j ACCEPT 2> /dev/null
-}
-
-start_ptunnel() {
+start_instance() {
        local section="$1"
 
        config_get interface "$section" interface
        config_get ifname "$interface" ifname
 
        [ -z "$ifname" ] && {
-               echo "Error: Interface '$interface' not found" 1>&2
+               echo "${initscript}: Error: Interface '$interface' not found" 1>&2
                return 1
        }
 
-       PIDCOUNT="$(( ${PIDCOUNT} + 1))"
-       ${BIN} -c "$ifname" -daemon /var/run/ptunnel."$PIDCOUNT".pid> /dev/null
+       SERVICE_PID_FILE="/var/run/ptunnel.$ifname.pid"
+       service_start /usr/sbin/ptunnel -c "$ifname" -daemon $SERVICE_PID_FILE
 }
 
-stop() {
-       local pidfile
+start() {
+       include /lib/network
+       scan_interfaces
 
-       for pidfile in `ls /var/run/${BIN}.*.pid`
-       do
-               start-stop-daemon -K -s KILL -p "${pidfile}" -n "${BIN}" >/dev/null
-               rm -f "${pidfile}"
-       done
+       config_load 'ptunnel'
+       config_foreach start_instance 'ptunnel'
+       iptables -I OUTPUT 1 -p icmp -j ACCEPT 2> /dev/null
+}
+
+stop() {
+       service_stop /usr/sbin/ptunnel
 }