ipq806x: enable vfpv4 support and set cpu type to cortex-a9
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Nov 2015 14:22:24 +0000 (14:22 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Nov 2015 14:22:24 +0000 (14:22 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47468 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk
target/linux/ipq806x/Makefile

index 102b3a0..f129298 100644 (file)
@@ -244,6 +244,7 @@ ifeq ($(DUMP),1)
       CPU_CFLAGS_neon = -mfpu=neon
       CPU_CFLAGS_vfp = -mfpu=vfp
       CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
+      CPU_CFLAGS_neon-vfpv4 = -mfpu=neon-vfpv4
     endif
   endif
   ifeq ($(ARCH),powerpc)
index 45f83dd..97a40cf 100644 (file)
@@ -6,7 +6,8 @@ ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
 FEATURES:=squashfs nand ubifs
-CPU_TYPE:=cortex-a7
+CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=neon-vfpv4
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 KERNEL_PATCHVER:=3.18