mvebu: add a subprofile for boards based on a small NOR
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Feb 2015 11:25:21 +0000 (11:25 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Feb 2015 11:25:21 +0000 (11:25 +0000)
Some boards only come with a small NOR on it, where UBI isn't a good solution
because of its overhead.

Add a new subprofile for such boards, that rely on the mtd split framework
instead.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44263 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/mvebu/image/Makefile

index 7076e87..a8fc4de 100644 (file)
@@ -77,6 +77,31 @@ define UBINORProfile
 endef
 
 # $(1): Profile Name
+# $(2): DTB Name
+# $(3): Erase Block Size
+define NORProfile
+  define Image/BuildKernel/Profile/$(1)
+       $(call Image/Build/DTB,$(2))
+    ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+       $(call Image/Build/Profile,$(1)/Initramfs)
+    endif
+  endef
+
+  define Image/Build/Profile/$(1)/Initramfs
+       $(call Image/Build/DTB,$(2),-initramfs)
+  endef
+
+  define Image/Build/Profile/$(1)/squashfs
+       ( \
+               dd if=$(KDIR)/uImage-$(2) bs=$(3) conv=sync; \
+               dd if=$(KDIR)/root.squashfs bs=$(3) conv=sync; \
+       ) > $$(BIN_DIR)/$$(IMG_PREFIX)-$(2)-squashfs-firmware.bin
+  endef
+
+  PROFILES_LIST += $(1)
+endef
+
+# $(1): Profile Name
 # $(2): Sub Profiles list
 define MultiProfile
   define Image/BuildKernel/Profile/$(1)