fix .pkginfo line to allow the use of $(SOURCE)
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 19 May 2006 23:02:14 +0000 (23:02 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 19 May 2006 23:02:14 +0000 (23:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3802 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
package/busybox/Makefile

index 9b9d1c9..9b341f1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -41,11 +41,11 @@ export OPENWRTVERSION
 all:
 
 .pkginfo: FORCE
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
        @echo Collecting package info...
-       @-for makefile in package/*/Makefile; do \
-               echo Source-Makefile: $$makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -f $$makefile 2>&- || true; \
+       @-for dir in package/*/; do \
+               echo Source-Makefile: $${dir}Makefile; \
+               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
 endif
 
index ff23ee7..cc36301 100644 (file)
@@ -23,10 +23,11 @@ TITLE:=Core utilities for embedded Linux
 DESCRIPTION:=The Swiss Army Knife of embedded Linux. \\\
 It slices, it dices, it makes Julian Fries.
 URL:=http://busybox.net/
-CONFIG:=menu "Configuration" \\\
-       depends on PACKAGE_busybox \\\
-source "package/busybox/config/Config.in" \\\
-endmenu
+CONFIG:=\\\
+       menu "Configuration" \\\
+               depends on PACKAGE_busybox \\\
+               source "$(SOURCE)/config/Config.in" \\\
+       endmenu
 endef
 
 define Build/Configure