ead: fix compile errors with recent kernels
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Jul 2013 12:56:07 +0000 (12:56 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Jul 2013 12:56:07 +0000 (12:56 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37482 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/ead/Makefile
package/network/services/ead/src/libbridge.h

index 5633a31..a3bfb1c 100644 (file)
@@ -33,7 +33,6 @@ endef
 CONFIGURE_PATH = tinysrp
 
 TARGET_CFLAGS += \
-       -I$(LINUX_DIR)/include \
        -I$(PKG_BUILD_DIR) \
        -I$(PKG_BUILD_DIR)/tinysrp \
        $(TARGET_CPPFLAGS)
index 6b70e46..13c8c64 100644 (file)
@@ -21,6 +21,7 @@
 
 #include <sys/socket.h>
 #include <linux/if.h>
+#include <linux/in6.h>
 #include <linux/if_bridge.h>
 
 /* defined in net/if.h but that conflicts with linux/if.h... */