x86: switch rdc to to gpio_keys_polled
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 19 Jul 2013 13:20:39 +0000 (13:20 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 19 Jul 2013 13:20:39 +0000 (13:20 +0000)
gpio_buttons have been deprecated since a long time.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37435 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/patches-3.3/100-rdc_boards.patch
target/linux/x86/patches-3.7/100-rdc_boards.patch
target/linux/x86/patches-3.8/100-rdc_boards.patch
target/linux/x86/rdc/target.mk

index 958bee0..b3cbda2 100644 (file)
@@ -67,7 +67,7 @@
 +
 +/* Button */
 +static struct platform_device rdc321x_buttons = {
-+      .name = "gpio-buttons",
++      .name = "gpio-keys-polled",
 +      .id = -1,
 +      .dev = {
 +              .platform_data = &rdcplat_data.button_data,
 +static struct gpio_led ar525w_leds[] = {
 +      { .name = "rdc321x:dmz", .gpio = 1, .active_low = 1},
 +};
-+static struct gpio_button ar525w_btns[] = {
++static struct gpio_keys_button ar525w_btns[] = {
 +      {
 +              .gpio = 6,
 +              .code = BTN_0,
 +      { .name = "rdc321x:usb1", .gpio = 1, .active_low = 1},
 +};
 +
-+static struct gpio_button sitecom_btns[] = {
++static struct gpio_keys_button sitecom_btns[] = {
 +      {
 +              .gpio = 6,
 +              .code = BTN_0,
 +#define _RDC_BOARDS_H__
 +
 +#include <linux/leds.h>
-+#include <linux/gpio_buttons.h>
++#include <linux/gpio_keys.h>
 +
 +struct rdc_platform_data {
 +      struct gpio_led_platform_data led_data;
-+      struct gpio_buttons_platform_data button_data;
++      struct gpio_keys_platform_data button_data;
 +};
 +
 +#endif
index 48c42f7..462808e 100644 (file)
@@ -67,7 +67,7 @@
 +
 +/* Button */
 +static struct platform_device rdc321x_buttons = {
-+      .name = "gpio-buttons",
++      .name = "gpio-keys-polled",
 +      .id = -1,
 +      .dev = {
 +              .platform_data = &rdcplat_data.button_data,
 +static struct gpio_led ar525w_leds[] = {
 +      { .name = "rdc321x:dmz", .gpio = 1, .active_low = 1},
 +};
-+static struct gpio_button ar525w_btns[] = {
++static struct gpio_keys_button ar525w_btns[] = {
 +      {
 +              .gpio = 6,
 +              .code = BTN_0,
 +      { .name = "rdc321x:usb1", .gpio = 1, .active_low = 1},
 +};
 +
-+static struct gpio_button sitecom_btns[] = {
++static struct gpio_keys_button sitecom_btns[] = {
 +      {
 +              .gpio = 6,
 +              .code = BTN_0,
 +#define _RDC_BOARDS_H__
 +
 +#include <linux/leds.h>
-+#include <linux/gpio_buttons.h>
++#include <linux/gpio_keys.h>
 +
 +struct rdc_platform_data {
 +      struct gpio_led_platform_data led_data;
-+      struct gpio_buttons_platform_data button_data;
++      struct gpio_keys_platform_data button_data;
 +};
 +
 +#endif
index 5880610..c70874a 100644 (file)
@@ -67,7 +67,7 @@
 +
 +/* Button */
 +static struct platform_device rdc321x_buttons = {
-+      .name = "gpio-buttons",
++      .name = "gpio-keys-polled",
 +      .id = -1,
 +      .dev = {
 +              .platform_data = &rdcplat_data.button_data,
 +static struct gpio_led ar525w_leds[] = {
 +      { .name = "rdc321x:dmz", .gpio = 1, .active_low = 1},
 +};
-+static struct gpio_button ar525w_btns[] = {
++static struct gpio_keys_button ar525w_btns[] = {
 +      {
 +              .gpio = 6,
 +              .code = BTN_0,
 +      { .name = "rdc321x:usb1", .gpio = 1, .active_low = 1},
 +};
 +
-+static struct gpio_button sitecom_btns[] = {
++static struct gpio_keys_button sitecom_btns[] = {
 +      {
 +              .gpio = 6,
 +              .code = BTN_0,
 +#define _RDC_BOARDS_H__
 +
 +#include <linux/leds.h>
-+#include <linux/gpio_buttons.h>
++#include <linux/gpio_keys.h>
 +
 +struct rdc_platform_data {
 +      struct gpio_led_platform_data led_data;
-+      struct gpio_buttons_platform_data button_data;
++      struct gpio_keys_platform_data button_data;
 +};
 +
 +#endif
index 959a8a1..c958945 100644 (file)
@@ -5,8 +5,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 DEFAULT_PACKAGES += kmod-llc kmod-stp kmod-bridge kmod-8021q \
                    wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
-                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
-                   kmod-rdc321x-wdt
+                   kmod-input-polldev kmod-button-hotplug kmod-rdc321x-wdt
 
 define Target/Description
         Build firmware images for RDC321x based routers