target/linux/*/image/Makefile: eliminate more LINUX_DIR users
authorJohn Crispin <blogic@openwrt.org>
Mon, 21 Jul 2014 18:42:11 +0000 (18:42 +0000)
committerJohn Crispin <blogic@openwrt.org>
Mon, 21 Jul 2014 18:42:11 +0000 (18:42 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41792 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-defaults.mk
target/linux/malta/image/Makefile
target/linux/xburst/image/Makefile

index f1f5a81..da06abd 100644 (file)
@@ -140,6 +140,7 @@ endif
 define Kernel/CopyImage
        $(KERNEL_CROSS)objcopy -O binary $(OBJCOPY_STRIP) -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)$(1)
        $(KERNEL_CROSS)objcopy $(OBJCOPY_STRIP) -S $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/vmlinux$(1).elf
+       $(CP) $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/vmlinux.debug
 ifneq ($(subst ",,$(KERNELNAME)),)
        #")
        $(foreach k,$(filter-out dtbs,$(subst ",,$(KERNELNAME))),$(CP) $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/$(IMAGES_DIR)/$(k) $(KERNEL_BUILD_DIR)/$(k)$(1);)
index c0e520f..db2637a 100644 (file)
@@ -21,7 +21,7 @@ endef
 
 define MkuImage
        mkimage -A mips -O linux -T kernel -a 0x80100000 -C $(1) $(2) \
-               -e $(call get_kernel_entry,$(LINUX_DIR)/vmlinux) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -e $(call get_kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
                -d $(3) $(4)
 endef
 
index 0de5560..49bb254 100644 (file)
@@ -27,7 +27,7 @@ endef
 define MkImageGzip
        gzip -9 -c $(1) > $(1).gz
        mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
-               -e $(call kernel_entry,$(LINUX_DIR)/vmlinux) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -e $(call kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
                -d $(1).gz $(2)
 endef