ar71xx: create profile and build image for the OpenMesh MR600 board
authorGabor Juhos <juhosg@openwrt.org>
Sun, 18 Nov 2012 09:32:41 +0000 (09:32 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 18 Nov 2012 09:32:41 +0000 (09:32 +0000)
Signed-off-by: Marek Lindner <lindner_marek@yahoo.de>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34237 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/generic/profiles/openmesh.mk
target/linux/ar71xx/image/Makefile

index 975a7ed..92aec4b 100644 (file)
@@ -16,3 +16,14 @@ endef
 
 $(eval $(call Profile,OM2P))
 
+define Profile/MR600
+        NAME:=OpenMesh MR600
+        PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/MR600/Description
+        Package set optimized for the OpenMesh MR600.
+endef
+
+$(eval $(call Profile,MR600))
+
index e212348..48893e6 100644 (file)
@@ -832,6 +832,7 @@ $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDRMAC,wndrmac,WNDR3700,ttyS0,115
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDRMACV2,wndrmacv2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMACv2,"",-H 29763654+16+128))
 
 $(eval $(call SingleProfile,OpenMesh,$(fs_squash),OM2P,om2p,,,,OM2P))
+$(eval $(call SingleProfile,OpenMesh,$(fs_squash),MR600,mr600,,,,MR600))
 
 $(eval $(call SingleProfile,PB4X,$(fs_128k),ALL0305,all0305,ALL0305,ttyS0,115200))
 $(eval $(call SingleProfile,PB4X,$(fs_128k),EAP7660D,eap7660d,EAP7660D,ttyS0,115200))