[brcm63xx] switch to gpio-keys-polled
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Apr 2012 16:44:48 +0000 (16:44 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Apr 2012 16:44:48 +0000 (16:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31491 3c298f89-4303-0410-b956-a3cf2f4a3e73

16 files changed:
target/linux/brcm63xx/Makefile
target/linux/brcm63xx/patches-3.3/300-reset_buttons.patch
target/linux/brcm63xx/patches-3.3/302-extended-platform-devices.patch
target/linux/brcm63xx/patches-3.3/500-board-D4PW.patch
target/linux/brcm63xx/patches-3.3/501-board-NB4.patch
target/linux/brcm63xx/patches-3.3/503-board-CPVA642.patch
target/linux/brcm63xx/patches-3.3/504-board_dsl_274xb_rev_c.patch
target/linux/brcm63xx/patches-3.3/505-board_spw500v.patch
target/linux/brcm63xx/patches-3.3/506-board_gw6200_gw6000.patch
target/linux/brcm63xx/patches-3.3/510-board_spw303v.patch
target/linux/brcm63xx/patches-3.3/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.3/512-board_BTV2110.patch
target/linux/brcm63xx/patches-3.3/514-board_ct536_ct5621.patch
target/linux/brcm63xx/patches-3.3/516-board_96348A-122.patch
target/linux/brcm63xx/patches-3.3/550-alice_gate2_leds.patch
target/linux/brcm63xx/patches-3.3/552-board_96348gw-10_reset_button.patch

index 525903c..5f64ee7 100644 (file)
@@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-switch kmod-input-gpio-buttons \
+DEFAULT_PACKAGES += kmod-switch kmod-input-gpio-keys-polled \
        kmod-button-hotplug
 
 define Target/Description
index ef57ff8..9420b8b 100644 (file)
@@ -4,7 +4,7 @@
  #include <linux/mtd/partitions.h>
  #include <linux/mtd/physmap.h>
  #include <linux/ssb/ssb.h>
-+#include <linux/gpio_buttons.h>
++#include <linux/gpio_keys.h>
 +#include <linux/input.h>
  #include <asm/addrspace.h>
  #include <bcm63xx_board.h>
@@ -20,7 +20,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
  };
@@ -37,7 +37,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
  };
        .dev.platform_data      = &bcm63xx_led_data,
  };
  
-+static struct gpio_buttons_platform_data bcm63xx_gpio_buttons_data = {
++static struct gpio_keys_platform_data bcm63xx_gpio_keys_data = {
 +      .poll_interval  = 20,
 +};
 +
-+static struct platform_device bcm63xx_gpio_buttons_device = {
-+      .name           = "gpio-buttons",
++static struct platform_device bcm63xx_gpio_keys_device = {
++      .name           = "gpio-keys-polled",
 +      .id             = 0,
-+      .dev.platform_data = &bcm63xx_gpio_buttons_data,
++      .dev.platform_data = &bcm63xx_gpio_keys_data,
 +};
 +
  /*
 +              button_count++;
 +
 +      if (button_count) {
-+              bcm63xx_gpio_buttons_data.nbuttons = button_count;
-+              bcm63xx_gpio_buttons_data.buttons = board.buttons;
++              bcm63xx_gpio_keys_data.nbuttons = button_count;
++              bcm63xx_gpio_keys_data.buttons = board.buttons;
 +
-+              platform_device_register(&bcm63xx_gpio_buttons_device);
++              platform_device_register(&bcm63xx_gpio_keys_device);
 +      }
 +
        return 0;
@@ -90,7 +90,7 @@
  
  #include <linux/types.h>
  #include <linux/gpio.h>
-+#include <linux/gpio_buttons.h>
++#include <linux/gpio_keys.h>
  #include <linux/leds.h>
  #include <bcm63xx_dev_enet.h>
  #include <bcm63xx_dev_dsp.h>
        struct gpio_led leds[5];
 +
 +      /* Buttons */
-+      struct gpio_button buttons[4];
++      struct gpio_keys_button buttons[4];
  };
  
  #endif /* ! BOARD_BCM963XX_H_ */
index 8e0ecaf..9d9d6ce 100644 (file)
@@ -15,7 +15,7 @@
 @@ -61,6 +61,10 @@ struct board_info {
  
        /* Buttons */
-       struct gpio_button buttons[4];
+       struct gpio_keys_button buttons[4];
 +
 +      /* Additional platform devices */
 +      struct platform_device **devs;
index aa92bbc..5a769dc 100644 (file)
@@ -48,7 +48,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
index d70d00b..e1e85ba 100644 (file)
 +                      .gpio           = 34,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "wps",
 +                      .gpio           = 37,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_WPS_BUTTON,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +      .devs = nb4_devices,
 +                      .gpio           = 34,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "wps",
 +                      .gpio           = 37,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_WPS_BUTTON,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +      .devs = nb4_devices,
 +                      .gpio           = 34,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "wps",
 +                      .gpio           = 37,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_WPS_BUTTON,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +      .devs = nb4_devices,
 +                      .gpio           = 34,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "wps",
 +                      .gpio           = 37,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_WPS_BUTTON,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +      .devs = nb4_devices,
 +                      .gpio           = 34,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "wps",
 +                      .gpio           = 37,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_WPS_BUTTON,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +      .devs = nb4_devices,
index 28bd9b1..d969e22 100644 (file)
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "wps",
 +                      .gpio           = 37,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_WPS_BUTTON,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
index 43818a2..375c824 100644 (file)
@@ -52,7 +52,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
index 89adf93..fff5d68 100644 (file)
@@ -60,7 +60,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
index 05c2d5e..a82f2b0 100644 (file)
@@ -61,7 +61,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
index 7b7e7e0..2002ab4 100644 (file)
@@ -58,7 +58,7 @@
 +                      .gpio           = 11,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "ses",
@@ -66,7 +66,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_WPS_BUTTON,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      }
 +};
index bc9ea8b..e90e6cc 100644 (file)
@@ -56,7 +56,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
index 7469243..07d7049 100644 (file)
@@ -54,7 +54,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
index 1418020..f682fe5 100644 (file)
@@ -42,7 +42,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
index 28a2b4b..6729230 100644 (file)
@@ -44,7 +44,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "wifi",
@@ -52,7 +52,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = BTN_0,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "wps",
@@ -60,7 +60,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_WPS_BUTTON,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
 +};
index 82d0385..b6bf40f 100644 (file)
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +              {
 +                      .desc           = "wps",
 +                      .gpio           = 34,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_WPS_BUTTON,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
  };
index dcd65ba..eeaad03 100644 (file)
@@ -12,7 +12,7 @@
 +                      .active_low     = 1,
 +                      .type           = EV_KEY,
 +                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
++                      .debounce_interval = 60,
 +              },
 +      },
  };