make sure quilt starts with the correct patch order in series
authorFelix Fietkau <nbd@openwrt.org>
Mon, 18 Jun 2007 00:11:27 +0000 (00:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 18 Jun 2007 00:11:27 +0000 (00:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7658 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/quilt.mk

index e02fab0..4719529 100644 (file)
@@ -57,6 +57,10 @@ endef
 
 $(STAMP_PATCHED): $(STAMP_PREPARED)
        @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
+       (\
+               cd $(PKG_BUILD_DIR)/patches; \
+               find * -type f \! -name series | sort > series; \
+       )
        [ -f "$(PKG_BUILD_DIR)/patches/series" ] && cd $(PKG_BUILD_DIR); quilt push -a
        touch $@