Merge branch 'master' of git.nanl.de:openwrt/telephony
authorMazi Lo <openwrt.mazilo@recursor.net>
Tue, 29 Oct 2013 04:32:36 +0000 (00:32 -0400)
committerMazi Lo <openwrt.mazilo@recursor.net>
Tue, 29 Oct 2013 04:32:36 +0000 (00:32 -0400)
net/freeswitch/Config.in
net/freeswitch/Makefile

index b08e287..e8c114f 100644 (file)
@@ -63,6 +63,12 @@ config FS_WITH_ALSA
     help
        Compile $(PKG_NAME) with ALSA support.
 
+config FS_WITH_VISIBILITY
+    bool "Enable API visibility support"
+    default y
+    help
+       Compile $(PKG_NAME) with API visibility support.
+
 config FS_WITH_BUILTIN_ZRTP
     bool "Enable built-in ZRTP"
     default y
@@ -83,6 +89,15 @@ config FS_WITH_LZMA
        Compile libs/tiff package with liblzma support. This option requires
        LZMA2 compression package called liblzma.
 
+config FS_WITH_ODBC
+    depends on PACKAGE_sqliteodbc
+    depends on PACKAGE_unixodbc_svn
+    bool "Compile with ODBC support (Requires unixodbc_svn NOT YET AVAILABLE)"
+    default n
+    help
+       Compile $(PKG_NAME) with ODBC support. Since both sqliteodbc and unixodbc_svn packages
+       are not yet available on OpenWRT, $(PKG_NAME) CAN NOT be compiled with ODBC support.
+
 config FS_WITH_OPENSSL
     bool "Enable SSL support"
     default y
@@ -103,12 +118,16 @@ config FS_WITH_SCTP
     help
        Compile $(PKG_NAME) with SCTP support in lib APR.
 
-config FS_WITH_ODBC
-    depends on PACKAGE_sqliteodbc
-    depends on PACKAGE_unixodbc_svn
-    bool "Compile with ODBC support (Requires unixodbc_svn NOT YET AVAILABLE)"
-    default n
+config FS_WITH_SRTP
+    bool "Enable SRTP"
+    default y
     help
-       Compile $(PKG_NAME) with ODBC support. Since both sqliteodbc and unixodbc_svn packages
-       are not yet available on OpenWRT, $(PKG_NAME) CAN NOT be compiled with ODBC support.
+       Compile $(PKG_NAME) with SRTP support.
+
+config FS_WITH_THREADS
+    bool "Enable threading support in APR"
+    default y
+    help
+       Compile $(PKG_NAME) with threads support in libs/apr.
+
 endmenu
index f8edebd..88ee032 100644 (file)
@@ -19,7 +19,7 @@ PKG_VERSION:=1.5.6b
 # http://fisheye.freeswitch.org
 #
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
-FS_DEFAULT_HEAD:=c8be999c3446ffc8a4bbe10116855e542b29129e
+FS_DEFAULT_HEAD:=40c105322193b7d0160814ed8ffcd5bf7f566944
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_WITH_LATEST_HEAD),$(shell git ls-remote $(PKG_SOURCE_URL) HEAD|cut -f1),$(FS_DEFAULT_HEAD))
 PKG_SOURCE_VERSION_SHORT:=$(shell echo $(PKG_SOURCE_VERSION)|cut -b -7)
 PKG_RELEASE:=$(PKG_SOURCE_VERSION_SHORT)
@@ -32,6 +32,9 @@ PKG_FIXUP:=libtool autoreconf
 PKG_BUILD_PARALLEL:=1
 
 
+TAR_OPTIONS+= --strip-components=1 -C $(PKG_BUILD_DIR)
+
+
 FS_MOD_AVAILABLE:= \
        abstraction \
        alsa \
@@ -161,6 +164,7 @@ FS_MOD_AVAILABLE:= \
        xml-cdr \
        xml-curl \
        xml-rpc \
+       xml-radius \
        xml-scgi \
        yaml \
 
@@ -180,6 +184,9 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_FS_WITH_POSTGRESQL \
        CONFIG_FS_WITH_SQLITE3 \
        CONFIG_FS_WITH_SCTP \
+       CONFIG_FS_WITH_SRTP \
+       CONFIG_FS_WITH_THREADS \
+       CONFIG_FS_WITH_VISIBILITY \
        $(patsubst %,CONFIG_PACKAGE_$(PKG_NAME)-mod-%,$(FS_MOD_AVAILABLE)) \
 
 
@@ -187,9 +194,6 @@ include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
 
-TAR_OPTIONS+= --strip-components=1 -C $(PKG_BUILD_DIR)
-
-
 define Package/$(PKG_NAME)/Default
   SECTION:=net
   CATEGORY:=Network
@@ -509,6 +513,7 @@ CONFIGURE_ARGS+= \
        --with-modinstdir="/usr/lib/$(PKG_NAME)" \
        --with-random="/dev/urandom" \
        $(if $(CONFIG_FS_WITH_MYSQL),--with,--without)-mysql \
+       $(if $(CONFIG_FS_WITH_POSTGRESQL),--with,--without)-pgsql \
        $(if $(CONFIG_FS_WITH_SQLITE3),--with,--without)-sqlite3 \
        $(call autoconf_bool,CONFIG_FS_WITH_IPV6,ipv6) \
        $(if $(CONFIG_FS_WITH_OPENSSL),--with,--without)-openssl \
@@ -519,11 +524,15 @@ CONFIGURE_ARGS+= \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-java),--with-java="$(STAGING_DIR)/usr",--without-java) \
        $(call autoconf_bool,CONFIG_FS_WITH_LZMA,lzma) \
        $(call autoconf_bool,CONFIG_FS_WITH_POSTGRESQL,core-pgsql-support) \
+       $(call autoconf_bool,CONFIG_FS_WITH_POSTGRESQL,core-pgsql-pkgconfig) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-spandsp && CONFIG_FS_WITH_FIXED_POINT,fixed-point) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-spandsp,builtin-tiff) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-timerfd,timerfd-wrapper) \
+       $(call autoconf_bool,CONFIG_FS_WITH_SRTP,srtp) \
        $(call autoconf_bool,CONFIG_FS_WITH_BUILTIN_ZRTP,zrtp) \
        $(call autoconf_bool,CONFIG_FS_WITH_ODBC,core-odbc-support) \
+       $(call autoconf_bool,CONFIG_FS_WITH_THREADS,threads) \
+       $(call autoconf_bool,CONFIG_FS_WITH_VISIBILITY,visibility) \
        $(if $(CONFIG_FS_WITH_ODBC),--with-odbc="$(STAGING_DIR)/usr") \
        $(if $(CONFIG_FS_WITH_ODBC),--with-odbc-lib="$(STAGING_DIR)/usr/lib") \
 
@@ -1017,5 +1026,6 @@ $(eval $(call BuildPlugin,vp8,VP8 Video Codec,vanilla,,,,))
 $(eval $(call BuildPlugin,xml-cdr,XML-CDR Handler,vanilla,,,,+libcurl))
 $(eval $(call BuildPlugin,xml-curl,XML-Curl Gateway,vanilla,,,,+libcurl))
 $(eval $(call BuildPlugin,xml-rpc,XML-RPC Interface,vanilla,,,,))
+$(eval $(call BuildPlugin,xml-radius,Radius authentication and authorization,vanilla,,,,+freeradius-client @BROKEN)) # freeradius-client isn't yet supported by OpenWRT.
 $(eval $(call BuildPlugin,xml-scgi,SCGI XML Gateway,vanilla,,,,))
 $(eval $(call BuildPlugin,yaml,YAML langunage,vanilla,,,,))