oxnas: fix itb generation
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Feb 2015 21:18:48 +0000 (21:18 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Feb 2015 21:18:48 +0000 (21:18 +0000)
- according to imx6 Makefile and u-Boot documentation is itb
  and probably should not be changed
- this fixes build error if CONFIG_TARGET_ROOTFS_INCLUDE_FIT is set
  (missing .itb file)
- use DTS_DIR (like in imx6 Makefile)

only compile tested

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Acked-by: Daniel Golle <daniel@makrotopia.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44468 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/oxnas/image/Makefile

index b09c67e..2660a9b 100644 (file)
@@ -28,10 +28,10 @@ $(shell echo $(PROFILE) | tr '[:upper:]' '[:lower:]' | sed 's/_/-/g')
 endef
 
 define Image/BuildKernel/Template
-       $(CP) $(LINUX_DIR)/arch/arm/boot/dts/ox820-$(1).dtb $(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb
+       $(CP) $(DTS_DIR)/ox820-$(1).dtb $(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb
 
        $(call Image/BuildKernel/MkFIT,$(1),$(KDIR)/zImage,$(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb,none,0x60008000,0x60008000)
-       $(CP) $(KDIR)/fit-$(1).itb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage.bin
+       $(CP) $(KDIR)/fit-$(1).itb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage.itb
 
  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
        $(call Image/BuildKernel/MkFIT,$(1),$(KDIR)/zImage-initramfs,$(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb,none,0x60008000,0x60008000,-initramfs)