[package/kernel]: remove references to 2.6.39
authorImre Kaloz <kaloz@openwrt.org>
Sat, 27 Oct 2012 13:47:23 +0000 (13:47 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 27 Oct 2012 13:47:23 +0000 (13:47 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33967 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/lib.mk
package/kernel/modules/other.mk
package/kernel/modules/video.mk

index 2875fb2..0411e93 100644 (file)
@@ -55,7 +55,6 @@ $(eval $(call KernelPackage,lib-crc7))
 define KernelPackage/lib-crc8
   SUBMENU:=$(LIB_MENU)
   TITLE:=CRC8 support
-  DEPENDS:= @!LINUX_2_6_39
   KCONFIG:=CONFIG_CRC8
   FILES:=$(LINUX_DIR)/lib/crc8.ko
   AUTOLOAD:=$(call AutoLoad,20,crc8)
@@ -154,7 +153,6 @@ $(eval $(call KernelPackage,lib-zlib))
 define KernelPackage/lib-cordic
   SUBMENU:=$(LIB_MENU)
   TITLE:=Cordic function support
-  DEPENDS:= @!LINUX_2_6_39
   KCONFIG:=CONFIG_CORDIC
   FILES:=$(LINUX_DIR)/lib/cordic.ko
   AUTOLOAD:=$(call AutoLoad,20,cordic)
index 352af28..607b065 100644 (file)
@@ -613,7 +613,6 @@ $(eval $(call KernelPackage,mtdtests))
 define KernelPackage/nand
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NAND flash support
-  DEPENDS:=@!LINUX_2_6_39
   KCONFIG:=CONFIG_MTD_NAND \
        CONFIG_MTD_NAND_IDS \
        CONFIG_MTD_NAND_ECC
index 94ea261..6c5de2e 100644 (file)
@@ -161,7 +161,7 @@ $(eval $(call KernelPackage,video-sn9c102))
 
 define KernelPackage/video-pwc
   TITLE:=Philips USB webcam support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +!LINUX_2_6_39:kmod-video-videobuf2
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
   KCONFIG:= \
        CONFIG_USB_PWC \
        CONFIG_USB_PWC_DEBUG=n