[kernel] upgrade to latest kernel versions (2.6.25.4; 2.6.24.7; 2.6.23.17; 2.6.22.19)
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 May 2008 20:12:54 +0000 (20:12 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 May 2008 20:12:54 +0000 (20:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11184 3c298f89-4303-0410-b956-a3cf2f4a3e73

23 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar7/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/etrax/Makefile
target/linux/ifxmips/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/magicbox/Makefile
target/linux/olpc/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ps3/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/sibyte/Makefile
target/linux/storm/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index f438106..aba715f 100644 (file)
@@ -3,7 +3,7 @@
 ifeq ($(KERNEL),2.4)
   LINUX_VERSION?=2.4.35.4
 else
-  LINUX_VERSION?=2.6.21.5
+  LINUX_VERSION?=2.6.21.7
 endif
 LINUX_RELEASE?=1
 
@@ -16,17 +16,17 @@ endif
 ifeq ($(LINUX_VERSION),2.6.21.7)
   LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
 endif
-ifeq ($(LINUX_VERSION),2.6.22.18)
-  LINUX_KERNEL_MD5SUM:=bd375d5885bf114c74a2216d52d86e34
+ifeq ($(LINUX_VERSION),2.6.22.19)
+  LINUX_KERNEL_MD5SUM:=4db27facb78aeb79d06e6ae6bf0ac0b6
 endif
-ifeq ($(LINUX_VERSION),2.6.23.16)
-  LINUX_KERNEL_MD5SUM:=2637a7f1d4450bc5e27422f307fc6529
+ifeq ($(LINUX_VERSION),2.6.23.17)
+  LINUX_KERNEL_MD5SUM:=a0300a393ac91ce9c64bf31522b45e2e
 endif
-ifeq ($(LINUX_VERSION),2.6.24.5)
-  LINUX_KERNEL_MD5SUM:=26500f8f92895bd33e391088b5edd4ad
+ifeq ($(LINUX_VERSION),2.6.24.7)
+  LINUX_KERNEL_MD5SUM:=40a73780d51525d28d36dec852c680c4
 endif
-ifeq ($(LINUX_VERSION),2.6.25.1)
-  LINUX_KERNEL_MD5SUM:=0d26fcafa00dc5cf27d4bf01301409a0
+ifeq ($(LINUX_VERSION),2.6.25.4)
+  LINUX_KERNEL_MD5SUM:=c2ec5007ee62e1b1ab05a1ca9155ebd3
 endif
 
 # disable the md5sum check for unknown kernel versions
index ec70098..af250e7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index 3abf34e..f5c6b99 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 87f156a..8a7d330 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=at91
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.21.7
 
 include $(INCLUDE_DIR)/target.mk
 
index ab301ba..5f5f9e4 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros 231x/5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 
index ec1a959..5a081f1 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 50b60f1..24f13af 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
index 56d1491..2af5210 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 119dbb2..db615ce 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 
index ea5fa0a..bfe84fe 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 4cb4ad6..f7556c2 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=iop32x
 BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index b02e749..e6b15e5 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 548b960..d539f98 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
index 9548b7b..915d11a 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=olpc
 BOARDNAME:=OLPC XO-1
 FEATURES:=squashfs ext2
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
index 11b052a..a571a19 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 1e4b9ed..90921e0 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 5bec1f5..14dbc97 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
 
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 KERNEL_CC:=
 
index 9e4fcca..43ad545 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci tgz
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 
index 42d4123..0b708fc 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rdc
 BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index df4539c..ac3633f 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=broken
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index c0d0023..abd6b0c 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=storm
 BOARDNAME:=Storm SL3512
 FEATURES:=squashfs pci broken
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 
index 543f703..022098a 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=broken ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 9943210..f85760b 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci