[kmod-usb2]: try to load the orion glue automatically
authorImre Kaloz <kaloz@openwrt.org>
Tue, 1 Jul 2014 09:36:38 +0000 (09:36 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 1 Jul 2014 09:36:38 +0000 (09:36 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41434 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/usb.mk

index 9aa3e8c..96c899a 100644 (file)
@@ -397,7 +397,7 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.8.0)),1)
   ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
     FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
   endif
-  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform,1)
+  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion,1)
 else
   FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko
   AUTOLOAD:=$(call AutoLoad,40,ehci-hcd,1)