build: add opkg host dependency
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Dec 2015 17:03:40 +0000 (17:03 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Dec 2015 17:03:40 +0000 (17:03 +0000)
fixes a missing host opkg
found by: unselect base-files, opkg

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47885 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile

index cc691b5..aa5d522 100644 (file)
@@ -91,7 +91,7 @@ PACKAGE_INSTALL_FILES:= \
 $(curdir)/cleanup: $(TMP_DIR)/.build
        rm -rf $(STAGING_DIR_ROOT)
 
-$(curdir)/install: $(TMP_DIR)/.build
+$(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
        - find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
        rm -rf $(TARGET_DIR)
        [ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp