x86: add generic profiles to x86_64, kvm_guest and xen_domu
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Nov 2015 20:39:24 +0000 (20:39 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Nov 2015 20:39:24 +0000 (20:39 +0000)
The imagebuilder requires a profile for every subtarget to work.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47421 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/64/profiles/000-Generic.mk [new file with mode: 0644]
target/linux/x86/kvm_guest/profiles/000-Generic.mk [new file with mode: 0644]
target/linux/x86/xen_domu/profiles/000-Generic.mk [new file with mode: 0644]

diff --git a/target/linux/x86/64/profiles/000-Generic.mk b/target/linux/x86/64/profiles/000-Generic.mk
new file mode 100644 (file)
index 0000000..ccd125a
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+endef
+
+define Profile/Generic/Description
+       Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/kvm_guest/profiles/000-Generic.mk b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
new file mode 100644 (file)
index 0000000..ccd125a
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+endef
+
+define Profile/Generic/Description
+       Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/xen_domu/profiles/000-Generic.mk b/target/linux/x86/xen_domu/profiles/000-Generic.mk
new file mode 100644 (file)
index 0000000..ccd125a
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+endef
+
+define Profile/Generic/Description
+       Generic Profile
+endef
+$(eval $(call Profile,Generic))