[include] version.mk: ensure that %S is always populated with a subtarget identifier...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Sep 2012 18:26:48 +0000 (18:26 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Sep 2012 18:26:48 +0000 (18:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33534 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/version.mk

index 4687dcc..2bf709e 100644 (file)
@@ -40,4 +40,4 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
        -e 's,%d,\L$(subst $(space),_,$(VERSION_DIST)),g' \
        -e 's,%R,$(REVISION),g' \
        -e 's,%T,$(BOARD),g' \
-       -e 's,%S,$(BOARD)$(if $(SUBTARGET),/$(SUBTARGET)),g' \
+       -e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \